diff mbox series

[bug#63218] gnu: babeltrace: Fix build failure.

Message ID 3d84fb99205dc84d30ac9d17e06ad0c6a5ad5fb5.1682988972.git.olivier.dion@polymtl.ca
State New
Headers show
Series [bug#63218] gnu: babeltrace: Fix build failure. | expand

Commit Message

Olivier Dion May 2, 2023, 12:56 a.m. UTC
* gnu/packages/instrumentation.scm (babeltrace)
[native-inputs]: Add autoconf, automake, libtool.
[arguments]: Invoke autoreconf before 'configure.
---
 gnu/packages/instrumentation.scm | 33 +++++++++++++++++++++++---------
 1 file changed, 24 insertions(+), 9 deletions(-)


base-commit: 39ba8a10971f15264966823e8696d63c2995df86

Comments

Ludovic Courtès May 2, 2023, 9:57 a.m. UTC | #1
Hi,

Olivier Dion <olivier.dion@polymtl.ca> skribis:

> * gnu/packages/instrumentation.scm (babeltrace)
> [native-inputs]: Add autoconf, automake, libtool.
> [arguments]: Invoke autoreconf before 'configure.

Applied, thanks!

Ludo’.
Olivier Dion May 2, 2023, 1:35 p.m. UTC | #2
On Tue, 02 May 2023, Ludovic Courtès <ludo@gnu.org> wrote:
> Applied, thanks!

If you don't mind checking 63213 while at it, it's the same fix but for
lttng-tools :-)
diff mbox series

Patch

diff --git a/gnu/packages/instrumentation.scm b/gnu/packages/instrumentation.scm
index c25086127a..114b100807 100644
--- a/gnu/packages/instrumentation.scm
+++ b/gnu/packages/instrumentation.scm
@@ -17,6 +17,7 @@ 
 ;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
 
 (define-module (gnu packages instrumentation)
+  #:use-module (gnu packages autotools)
   #:use-module (gnu packages base)
   #:use-module (gnu packages bash)
   #:use-module (gnu packages bison)
@@ -93,7 +94,8 @@  (define-public babeltrace
          (add-before 'configure 'set-environment-variables
            (lambda _
              (setenv "BABELTRACE_DEV_MODE" "1")
-             (setenv "BABELTRACE_MINIMAL_LOG_LEVEL" "TRACE"))))))
+             (setenv "BABELTRACE_MINIMAL_LOG_LEVEL" "TRACE")
+             (invoke "autoreconf" "-vfi"))))))
     (inputs
      (list glib))
     ;; NOTE - elfutils is used for the LTTng debug information filter
@@ -104,15 +106,28 @@  (define-public babeltrace
      (list elfutils))
     ;; NOTE - python-3 is set here for generating the bindings.  Users need to
     ;; install python-3 in their profile in order to use these bindings.
+    ;;
+    ;; NOTE - Babeltrace 2.0.4 is distributed with a aclocal.m4 that does not
+    ;; support Python3.10.  We can either disable Python's bindings or we can
+    ;; reconfigure the project with our autoconf.  This is because the
+    ;; distribution tarballs are generated on Ubuntu LTS 18.04.
+    ;;
+    ;; `paredit-raise-sexp' on the first list of native inputs and remove the
+    ;; 'autoreconf invokation whenever we bump to the next version that is
+    ;; goind to be generated on Ubuntu LTS 22.04.
     (native-inputs
-     (list asciidoc
-           bison
-           flex
-           pkg-config
-           python-3
-           python-sphinx
-           swig
-           xmltoman))
+     (append
+      (list asciidoc
+            bison
+            flex
+            pkg-config
+            python-3
+            python-sphinx
+            swig
+            xmltoman)
+      (list autoconf
+            automake
+            libtool)))
     (home-page "https://babeltrace.org/")
     (synopsis "Trace manipulation toolkit")
     (description "Babeltrace 2 is a framework for viewing, converting,