diff mbox series

[bug#68720] gnu: openmolar-1: Update to release 1.1.6-g81838c8 and partial runtime fix.

Message ID 3d5c2528d428ff4dd0c19e3ea43585d53c874478.1706218268.git.rimarko@libero.it
State New
Headers show
Series [bug#68720] gnu: openmolar-1: Update to release 1.1.6-g81838c8 and partial runtime fix. | expand

Commit Message

Marco Rimoldi Jan. 25, 2024, 9:31 p.m. UTC
From: Marco Rimoldi <rimarko@libero.it>

WebKit was removed from Qt5 in favor of WebEngine; upstream addressed this in their last stable release, in 2018.  The package still fails at runtime: this commit lays the ground for further fixes.

* gnu/packages/medical.scm (openmolar-1): Update to release 1.1.6-g81838c8.
[arguments]: Extend 'patch-/usr phase to source file localsettings.py.
[inputs]: Add python-pyqtwebengine.
[propagated-inputs]: Add qtwebengine-5.

Change-Id: Ia4e4c052397201c26834dec2358ca5c20beb581d
---
 gnu/packages/medical.scm | 54 +++++++++++++++++++++-------------------
 1 file changed, 28 insertions(+), 26 deletions(-)


base-commit: d6c394d6a177fdaf6b28f82a9dd2163633e5eeee

Comments

Marco Rimoldi Jan. 25, 2024, 9:43 p.m. UTC | #1
This commit fixes https://issues.guix.gnu.org/29365.

The package now fails to start with this error message:

File "/gnu/store/zzys4bqllx3a3gramwj2pyyigfb4z75b-openmolar-1.1.6-g81838c85/lib/python3.10/site-packages/openmolar/qt4gui/customwidgets/toothProps.py", line 827, in shapes
    self.mesial.setPoints(
TypeError: 'float' object cannot be interpreted as an integer

I will submit a new issue if the patch is accepted.

Marco
Ludovic Courtès Feb. 10, 2024, 9:56 p.m. UTC | #2
Hi,

Marco Rimoldi <rimarko@libero.it> skribis:

> This commit fixes https://issues.guix.gnu.org/29365.

Alright, applied!

> The package now fails to start with this error message:
>
> File "/gnu/store/zzys4bqllx3a3gramwj2pyyigfb4z75b-openmolar-1.1.6-g81838c85/lib/python3.10/site-packages/openmolar/qt4gui/customwidgets/toothProps.py", line 827, in shapes
>     self.mesial.setPoints(
> TypeError: 'float' object cannot be interpreted as an integer
>
> I will submit a new issue if the patch is accepted.

That’d be great.

Thanks!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/medical.scm b/gnu/packages/medical.scm
index 33877083e2..15bd870f83 100644
--- a/gnu/packages/medical.scm
+++ b/gnu/packages/medical.scm
@@ -83,32 +83,34 @@  (define-public mygnuhealth
 
 (define-public openmolar-1
   (package
-   (name "openmolar")
-   (version "1.0.15-gd81f9e5")
-   (source (origin
-             (method url-fetch)
-             (uri (string-append
-                   "https://static.openmolar.com/om1/releases/openmolar-"
-                   version ".tar.gz"))
-             (sha256
-              (base32
-               "1cfdzfbi6wslw7k0dc6ad6xrgs75iwsl91cg73w4myswaqqkfk3z"))))
-   (build-system python-build-system)
-   (arguments
-    `(#:use-setuptools? #f
-      #:phases
-      (modify-phases %standard-phases
-        (add-after 'unpack 'patch-/usr
-          (lambda* (#:key outputs #:allow-other-keys)
-            (substitute* "setup.py"
-              (("/usr") (assoc-ref outputs "out")))
-            #t)))))
-   (inputs
-    (list python-pyqt+qscintilla python-mysqlclient qscintilla))
-   (home-page "https://openmolar.com/om1")
-   (synopsis "Dental practice management software")
-   (description "Openmolar is a dental practice management suite.  Its
+    (name "openmolar")
+    (version "1.1.6-g81838c85")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://static.openmolar.com/om1/releases/openmolar-" version
+             ".tar.gz"))
+       (sha256
+        (base32 "09vrfqn511vswnj2q9m7srlwdgz066qvqpmja6sg1yl1ibh3cbpr"))))
+    (build-system python-build-system)
+    (arguments
+     `(#:use-setuptools? #f
+       #:phases (modify-phases %standard-phases
+                  (add-after 'unpack 'patch-/usr
+                    (lambda* (#:key outputs #:allow-other-keys)
+                      (substitute* '("setup.py"
+                                     "src/openmolar/settings/localsettings.py")
+                        (("/usr")
+                         (assoc-ref outputs "out"))) #t)))))
+    (inputs (list python-pyqtwebengine python-pyqt+qscintilla
+                  python-mysqlclient qscintilla))
+    (propagated-inputs (list qtwebengine-5))
+    (home-page "https://openmolar.com/om1")
+    (synopsis "Dental practice management software")
+    (description
+     "Openmolar is a dental practice management suite.  Its
 functionality includes appointments, patient records, treatment planning,
 billing etc.  It is a full featured, reliable and thoroughly tested
 application and has been translated into many languages.")
-   (license gpl3+)))
+    (license gpl3+)))