diff mbox series

[bug#72114] gnu: Add emacs-flycheck-clj-kondo

Message ID 3d49029f13564ef29b24b63d445880179349cf38.1720970605.git.daniel.szmulewicz@gmail.com
State New
Headers show
Series [bug#72114] gnu: Add emacs-flycheck-clj-kondo | expand

Commit Message

Daniel Szmulewicz July 14, 2024, 3:23 p.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-flycheck-clj-kondo): New variable.

Change-Id: Idc97832c7d3ae546152cb9458b07724e154bcb27
---
 gnu/packages/emacs-xyz.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)


base-commit: bcd627f58e74ce44cc96a9aac37c6d9e9e3c0dcc
prerequisite-patch-id: a806956c71c0cff17c07a84b45beded622ad41c2
prerequisite-patch-id: da033fc5dfae84475ce82d7ba2b55a2baef5d385
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 3b0d4c17cd..23e9520d8a 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -2793,6 +2793,30 @@  (define-public emacs-flycheck
 provides an optional IDE-like error list.")
     (license license:gpl3+)))                     ;+GFDLv1.3+ for the manual
 
+(define-public emacs-flycheck-clj-kondo
+  (package
+    (name "emacs-flycheck-clj-kondo")
+    (version "0.0.4-snapshot")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/borkdude/flycheck-clj-kondo.git")
+             (commit "e38c67ba9db1ea1cbe1b61ab39b506c05efdcdbf")))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1pxlb8axgmc8cw4id40z576kd041qb1irq8rkjn6xbda585ix58f"))))
+    (build-system emacs-build-system)
+    (propagated-inputs (list emacs-flycheck))
+    (home-page "https://github.com/borkdude/flycheck-clj-kondo")
+    (synopsis "Add clj-kondo linter to flycheck")
+    (description
+     "This package integrates clj-kondo with Emacs via flycheck.  To use it, add to
+your init.el: (require flycheck-clj-kondo) Make sure the clj-kondo binary is on
+your path.  For installation instructions, see
+https://github.com/borkdude/clj-kondo.")
+    (license license:gpl3+)))
+
 (define-public emacs-fb2-reader
   (let ((commit "9836db284749e0cef4c43c2cb5358c82ae9b8589")) ; version bump
     (package