diff mbox series

[bug#56282,3/7] gnu: Add r-mathjaxr.

Message ID 3d1c2a399c5e6d604c5c1f3891d2a833d79e1632.1656429407.git.code@greghogan.com
State Accepted
Headers show
Series Update octave. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Greg Hogan June 28, 2022, 3:22 p.m. UTC
* gnu/packages/cran.scm (r-mathjaxr): New variable.
---
 gnu/packages/cran.scm | 19 +++++++++++++++++++
 1 file changed, 19 insertions(+)

Comments

M June 30, 2022, 9:54 a.m. UTC | #1
Greg Hogan schreef op di 28-06-2022 om 15:22 [+0000]:
> * gnu/packages/cran.scm (r-mathjaxr): New variable.

This patch was (will be?) reverted as mentioned on #guix because ...

> +    (source (origin
> +              (method url-fetch)
> +              (uri (cran-uri "mathjaxr" version))
> +              (sha256
> +               (base32
> +                "0yf1sfkb2kjsplipl2v4k2gp20li9xzsynclg228sy0v243pdi7c"))))

... it bundles mathjax, and it isn't built from source.

> +    (properties `((upstream-name . "mathjaxr")))
> +    (build-system r-build-system)
> +    (home-page "https://github.com/wviechtb/mathjaxr")
> +    (synopsis "Using 'Mathjax' in Rd Files")
> +    (description
> +     "This package provides 'MathJax' and macros to enable its use within Rd files for
> +rendering equations in the HTML help files.")
> +    (license license:gpl3)))

also, the license information is incorrect -- the mathjax is
Apache 2.0, and it's a rather important component, so I think it should
be listed.

Greetings,
Maxime.
diff mbox series

Patch

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index bb2519bcda..b7387e444f 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -33459,3 +33459,22 @@  (define-public r-metadat
 purposes, illustrating/testing meta-analytic methods, and validating published
 analyses.")
     (license license:gpl2+)))
+
+(define-public r-mathjaxr
+  (package
+    (name "r-mathjaxr")
+    (version "1.6-0")
+    (source (origin
+              (method url-fetch)
+              (uri (cran-uri "mathjaxr" version))
+              (sha256
+               (base32
+                "0yf1sfkb2kjsplipl2v4k2gp20li9xzsynclg228sy0v243pdi7c"))))
+    (properties `((upstream-name . "mathjaxr")))
+    (build-system r-build-system)
+    (home-page "https://github.com/wviechtb/mathjaxr")
+    (synopsis "Using 'Mathjax' in Rd Files")
+    (description
+     "This package provides 'MathJax' and macros to enable its use within Rd files for
+rendering equations in the HTML help files.")
+    (license license:gpl3)))