diff mbox series

[bug#64918,3/3] gnu: Add ibus-table-others

Message ID 3d07888fc6628526478074294e618e71f18fbf91.1690548388.git.mcsinyx@disroot.org
State New
Headers show
Series gnu: Add ibus-table{,-others} | expand

Commit Message

vasilii.smirnov--- via Guix-patches" via July 28, 2023, 12:51 p.m. UTC
* gnu/packages/ibus.scm (ibus-table-others): New variable.
---
 gnu/packages/ibus.scm | 44 +++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 44 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/ibus.scm b/gnu/packages/ibus.scm
index a905ad78564e..aa98a1a06fab 100644
--- a/gnu/packages/ibus.scm
+++ b/gnu/packages/ibus.scm
@@ -941,6 +941,50 @@  (define-public ibus-table
       "ibus-table is a framework for table based input methods using IBus.")
     (license lgpl2.1+)))
 
+(define-public ibus-table-others
+  (package
+    (name "ibus-table-others")
+    (version "1.3.16")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (string-append
+               "https://github.com/moebiuscurve/ibus-table-others/releases/"
+               "download/" version "/ibus-table-others-" version ".tar.gz"))
+        (sha256
+          (base32 "0vllwrjlgcvdjhs7nrg45hfvnivnfhrc05r6rhw8m0c41layl9jg"))))
+    (build-system gnu-build-system)
+    (arguments
+      (list #:phases
+            #~(modify-phases %standard-phases
+                (add-before 'build 'pre-build
+                  (lambda _
+                    (setenv "HOME" (getcwd)))))))  ; db written in $HOME
+    (native-inputs (list pkg-config python))
+    (inputs (list ibus ibus-table))
+    (home-page "https://github.com/moebiuscurve/ibus-table-others")
+    (synopsis "Various table-based input methods for IBus")
+    (description
+      "ibus-table-others provides the following input methods on IBus-Table on IBus framework:
+@itemize
+@item CNS11643
+@item Compose
+@item Emoji
+@item IPA-X-SAMPA
+@item LaTex
+@item Mathwriter
+@item Mongol bichig
+@item RussianTraditional
+@item Telex
+@item Thai
+@item Translit
+@item Ua-Translit
+@item Viqr
+@item VNI
+@item Yawerty
+@end itemize")
+    (license gpl3)))
+
 (define-public ibus-speech-to-text
   (package
     (name "ibus-speech-to-text")