diff mbox series

[bug#68199,v2,1/2] gnu: taisei: Use gexps.

Message ID 3c76ff811b93f7e84067c1e2247e6b9acec829a4.1704239998.git.gemmaro.dev@gmail.com
State New
Headers show
Series [bug#68199,v2,1/2] gnu: taisei: Use gexps. | expand

Commit Message

gemmaro Jan. 2, 2024, 11:59 p.m. UTC
* gnu/packages/games.scm (taisei): Reformat with guix style.
  [arguments]: Use gexps.

Change-Id: If542566f43e581968f73537e90101a18d3b1bca1
---
 gnu/packages/games.scm | 66 +++++++++++++++++++++---------------------
 1 file changed, 33 insertions(+), 33 deletions(-)


base-commit: 86b5fa100992527c434616482ba9cfd92b636d12

Comments

Liliana Marie Prikler Jan. 5, 2024, 5:52 p.m. UTC | #1
Am Mittwoch, dem 03.01.2024 um 08:59 +0900 schrieb gemmaro:
> * gnu/packages/games.scm (taisei): Reformat with guix style.
>   [arguments]: Use gexps.
> 
> Change-Id: If542566f43e581968f73537e90101a18d3b1bca1
> ---
>  gnu/packages/games.scm | 66 +++++++++++++++++++++-------------------
> --
>  1 file changed, 33 insertions(+), 33 deletions(-)
> 
> diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
> index c7813790a1..4bbe97c3f9 100644
> --- a/gnu/packages/games.scm
> +++ b/gnu/packages/games.scm
> @@ -78,7 +78,7 @@
>  ;;; Copyright © 2023 Zheng Junjie <873216071@qq.com>
>  ;;; Copyright © 2023 Florian Pelz <pelzflorian@pelzflorian.de>
>  ;;; Copyright © 2023 Ivana Drazovic <iv.dra@hotmail.com>
> -;;; Copyright © 2023 gemmaro <gemmaro.dev@gmail.com>
> +;;; Copyright © 2023, 2024 gemmaro <gemmaro.dev@gmail.com>
>  ;;;
>  ;;; This file is part of GNU Guix.
>  ;;;
> @@ -3390,48 +3390,48 @@ (define-public taisei
>       (origin
>         (method url-fetch)
>         (uri (string-append "https://github.com/taisei-project/"
> -                           "taisei/releases/download/v" version
> -                           "/taisei-v" version ".tar.xz"))
> +                           "taisei/releases/download/v"
> +                           version
> +                           "/taisei-v"
> +                           version
> +                           ".tar.xz"))
That's a false positive in guix style, keep it as-is.
>         (sha256
>          (base32
> "1g53fcyrlzmvlsb40pw90gaglysv6n1w42hk263iv61ibhdmzh6v"))))
>      (build-system meson-build-system)
>      (arguments
> -     `(#:build-type "release"      ;comment out for bug-reporting
> (and cheats)
> -       #:configure-flags
> -       (list "-Dr_default=gles30"
> -             "-Dr_gles20=true"
> -             "-Dr_gles30=true"
> -             "-Dshader_transpiler=true")))
> -    (native-inputs
> -     (list pkg-config python python-docutils python-pygments))
> -    (inputs
> -     (list cglm
> -           freetype
> -           libpng
> -           libwebp
> -           libzip
> -           mesa
> -           openssl
> -           opusfile
> -           sdl2
> -           sdl2-mixer
> -           shaderc
> -           spirv-cross
> -           zlib))
> +     (list
> +      #:build-type "release" ;comment out for bug-reporting (and
> cheats)
> +      #:configure-flags #~(list "-Dr_default=gles30" "-
> Dr_gles20=true"
> +                                "-Dr_gles30=true" "-
> Dshader_transpiler=true")))
Here, having one flag per line actually helps, so split it.
> +    (native-inputs (list pkg-config python python-docutils python-
> pygments))
> +    (inputs (list cglm
> +                  freetype
> +                  libpng
> +                  libwebp
> +                  libzip
> +                  mesa
> +                  openssl
> +                  opusfile
> +                  sdl2
> +                  sdl2-mixer
> +                  shaderc
> +                  spirv-cross
> +                  zlib))
The same-line/next-line list is not too big of a deal, it can go either
way.
>      (home-page "https://taisei-project.org/")
>      (synopsis "Shoot'em up fangame and libre clone of Touhou
> Project")
>      (description
>       "The player controls a character (one of three: Good, Bad, and
> Dead),
>  dodges the missiles (lots of it cover the screen, but the
> character's hitbox
>  is very small), and shoot at the adversaries that keep appear on the
> screen.")
> -    (license (list ;;game
> -                   license:expat
> -                   ;;resources/00-taisei.pkgdir/bgm/
> -                   ;;atlas/portraits/
> -                   license:cc-by4.0
> -                   ;;miscellaneous
> -                   license:cc0
> -                   license:public-domain))))
> +    (license (list
> +              ;; game
> +              license:expat
> +              ;; resources/00-taisei.pkgdir/bgm/
> +              ;; atlas/portraits/
> +              license:cc-by4.0
> +              ;; miscellaneous
> +              license:cc0
> +              license:public-domain))))
This hunk LGTM.

Cheers
diff mbox series

Patch

diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index c7813790a1..4bbe97c3f9 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -78,7 +78,7 @@ 
 ;;; Copyright © 2023 Zheng Junjie <873216071@qq.com>
 ;;; Copyright © 2023 Florian Pelz <pelzflorian@pelzflorian.de>
 ;;; Copyright © 2023 Ivana Drazovic <iv.dra@hotmail.com>
-;;; Copyright © 2023 gemmaro <gemmaro.dev@gmail.com>
+;;; Copyright © 2023, 2024 gemmaro <gemmaro.dev@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -3390,48 +3390,48 @@  (define-public taisei
      (origin
        (method url-fetch)
        (uri (string-append "https://github.com/taisei-project/"
-                           "taisei/releases/download/v" version
-                           "/taisei-v" version ".tar.xz"))
+                           "taisei/releases/download/v"
+                           version
+                           "/taisei-v"
+                           version
+                           ".tar.xz"))
        (sha256
         (base32 "1g53fcyrlzmvlsb40pw90gaglysv6n1w42hk263iv61ibhdmzh6v"))))
     (build-system meson-build-system)
     (arguments
-     `(#:build-type "release"      ;comment out for bug-reporting (and cheats)
-       #:configure-flags
-       (list "-Dr_default=gles30"
-             "-Dr_gles20=true"
-             "-Dr_gles30=true"
-             "-Dshader_transpiler=true")))
-    (native-inputs
-     (list pkg-config python python-docutils python-pygments))
-    (inputs
-     (list cglm
-           freetype
-           libpng
-           libwebp
-           libzip
-           mesa
-           openssl
-           opusfile
-           sdl2
-           sdl2-mixer
-           shaderc
-           spirv-cross
-           zlib))
+     (list
+      #:build-type "release" ;comment out for bug-reporting (and cheats)
+      #:configure-flags #~(list "-Dr_default=gles30" "-Dr_gles20=true"
+                                "-Dr_gles30=true" "-Dshader_transpiler=true")))
+    (native-inputs (list pkg-config python python-docutils python-pygments))
+    (inputs (list cglm
+                  freetype
+                  libpng
+                  libwebp
+                  libzip
+                  mesa
+                  openssl
+                  opusfile
+                  sdl2
+                  sdl2-mixer
+                  shaderc
+                  spirv-cross
+                  zlib))
     (home-page "https://taisei-project.org/")
     (synopsis "Shoot'em up fangame and libre clone of Touhou Project")
     (description
      "The player controls a character (one of three: Good, Bad, and Dead),
 dodges the missiles (lots of it cover the screen, but the character's hitbox
 is very small), and shoot at the adversaries that keep appear on the screen.")
-    (license (list ;;game
-                   license:expat
-                   ;;resources/00-taisei.pkgdir/bgm/
-                   ;;atlas/portraits/
-                   license:cc-by4.0
-                   ;;miscellaneous
-                   license:cc0
-                   license:public-domain))))
+    (license (list
+              ;; game
+              license:expat
+              ;; resources/00-taisei.pkgdir/bgm/
+              ;; atlas/portraits/
+              license:cc-by4.0
+              ;; miscellaneous
+              license:cc0
+              license:public-domain))))
 
 (define-public cmatrix
   (package