[bug#76910,3/4] gnu: Add hy3.
Commit Message
* gnu/packages/wm.scm (hy3): New variable.
Change-Id: Id42dc76ab3440c7c651933c60b1ae30f8055afed
---
gnu/packages/wm.scm | 39 +++++++++++++++++++++++++++++++++++++++
1 file changed, 39 insertions(+)
@@ -567,6 +567,45 @@ (define-public hyprscroller
jump mode, and installation through hyprpm.")
(license license:expat)))
+(define-public hy3
+ (package
+ (name "hy3")
+ (version "0.47.0-1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/outfoxxed/hy3")
+ (commit (string-append "hl" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "02iayhdmw42ipy6j05qbnlpwqn74qyslczw7ikk3vxwrxh426iky"))))
+ (build-system cmake-build-system)
+ (native-inputs (list gcc-14 pkg-config))
+ (inputs (list aquamarine
+ eudev
+ hyprgraphics
+ hyprlang
+ hyprutils
+ libdrm
+ libinput
+ libxkbcommon
+ mesa
+ pango
+ pixman
+ wayland
+ hyprland))
+ (arguments
+ (list
+ #:tests? #f))
+ (home-page "https://github.com/outfoxxed/hy3")
+ (synopsis "Hyprland plugin for an i3/sway-like manual tiling layout")
+ (description
+ "hy3 is a Hyprland plugin providing an i3/sway-like manual
+tiling layout, including node-based window manipulation and optional
+autotiling.")
+ (license license:gpl3)))
+
(define-public i3status
(package
(name "i3status")