diff mbox series

[bug#64467] gnu: Add python-gixy.

Message ID 3c2dcb852f94b32b76be47e5e2e6a7194430ad63.1688509284.git.mirai@makinata.eu
State New
Headers show
Series [bug#64467] gnu: Add python-gixy. | expand

Commit Message

Bruno Victal July 4, 2023, 10:22 p.m. UTC
* gnu/packages/check.scm (python-gixy): New variable.
---
 gnu/packages/check.scm | 36 ++++++++++++++++++++++++++++++++++++
 1 file changed, 36 insertions(+)


base-commit: 9122736455a9085d51b71b269b7c26a695a474ef

Comments

Ludovic Courtès July 17, 2023, 10:30 p.m. UTC | #1
Bruno Victal <mirai@makinata.eu> skribis:

> * gnu/packages/check.scm (python-gixy): New variable.

Applied, thanks!
diff mbox series

Patch

diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index df57a778fe..4e8caadc82 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -43,6 +43,7 @@ 
 ;;; Copyright © 2022 jgart <jgart@dismail.de>
 ;;; Copyright © 2023 Luis Felipe López Acevedo <luis.felipe.la@protonmail.com>
 ;;; Copyright © 2023 Timo Wilken <guix@twilken.net>
+;;; Copyright © 2023 Bruno Victal <mirai@makinata.eu>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -811,6 +812,41 @@  (define-public doctest
 has been designed to be fast, light and unintrusive.")
     (license license:expat)))
 
+(define-public python-gixy
+  ;; The 0.1.20 release is missing some important fixes.
+  ;; XXX: Commit 'e9008dcbd11f43ccac109b0cf2bf98a94e76b449' breaks tests
+  ;; since it improperly removes an import.
+  (let ((commit "303eb6887ddecab18138b6e427b04ae77c41d2f1")
+        (revision "0")
+        (base-version "0.1.20"))
+    (package
+      (name "python-gixy")
+      (version (git-version base-version revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/yandex/gixy")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "0gymjcnvjx9snyrzdbmjnk93ibb161q72xam29vnl3yyac4r1330"))))
+      (build-system pyproject-build-system)
+      (native-inputs (list python-nose))
+      (propagated-inputs
+       (list python-cached-property python-configargparse
+             python-jinja2 python-six
+             ;; XXX: gixy is incompatible with pyparsing >= 3.x.
+             ;; See <https://github.com/yandex/gixy/pull/132> and
+             ;; <https://github.com/yandex/gixy/pull/122>.
+             python-pyparsing-2.4.7))
+      (home-page "https://github.com/yandex/gixy")
+      (synopsis "Static NGINX configuration analyzer")
+      (description "Gixy is a static analyzer whose main goal is to help
+prevent common NGINX misconfigurations.  It provides the @command{gixy}
+command.")
+      (license license:mpl2.0))))
+
 (define-public go-github.com-smartystreets-gunit
   (package
     (name "go-github.com-smartystreets-gunit")