diff mbox series

[bug#69610,3/3] gnu: Add superfluous-returnz.

Message ID 3c0e0bc0-9927-4ecf-3816-0ee51a1c3a4b@disroot.org
State New
Headers show
Series gnu: Add superfluous-returnz. | expand

Commit Message

Adam Faiz March 7, 2024, 12:44 p.m. UTC
From cf5541cbb52ca199872223178399d955e862ece3 Mon Sep 17 00:00:00 2001
Message-ID: <cf5541cbb52ca199872223178399d955e862ece3.1709814572.git.adam.faiz@disroot.org>
In-Reply-To: <cover.1709814572.git.adam.faiz@disroot.org>
References: <cover.1709814572.git.adam.faiz@disroot.org>
From: AwesomeAdam54321 <adam.faiz@disroot.org>
Date: Thu, 7 Mar 2024 12:59:28 +0800
Subject: [PATCH 3/3] gnu: Add superfluous-returnz.

* gnu/packages/games.scm (superfluous-returnz): New variable.
---
 gnu/packages/games.scm | 40 ++++++++++++++++++++++++++++++++++++++++
 1 file changed, 40 insertions(+)

Comments

Liliana Marie Prikler March 7, 2024, 6:23 p.m. UTC | #1
Am Donnerstag, dem 07.03.2024 um 20:44 +0800 schrieb Adam Faiz:
> From cf5541cbb52ca199872223178399d955e862ece3 Mon Sep 17 00:00:00
> 2001
> Message-ID:
> <cf5541cbb52ca199872223178399d955e862ece3.1709814572.git.adam.faiz@di
> sroot.org>
> In-Reply-To: <cover.1709814572.git.adam.faiz@disroot.org>
> References: <cover.1709814572.git.adam.faiz@disroot.org>
> From: AwesomeAdam54321 <adam.faiz@disroot.org>
> Date: Thu, 7 Mar 2024 12:59:28 +0800
> Subject: [PATCH 3/3] gnu: Add superfluous-returnz.
> 
> * gnu/packages/games.scm (superfluous-returnz): New variable.
> ---
>  gnu/packages/games.scm | 40 ++++++++++++++++++++++++++++++++++++++++
>  1 file changed, 40 insertions(+)
> 
> diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
> index 2ebd858ad6..c922029427 100644
> --- a/gnu/packages/games.scm
> +++ b/gnu/packages/games.scm
> @@ -2934,6 +2934,46 @@ (define-public superfluous-returnz-data
>      (home-page
> "https://studios.ptilouk.net/superfluous-returnz/floss/")
>      (license license:cc-by-sa4.0)))
>  
> +(define-public superfluous-returnz
> +  (package
> +    (name "superfluous-returnz")
The name does not appear to match up with the project name given below.
Now this might be excuses because despite claiming to be a game
"engine", it refuses to compile without the assets – a very interesting
design choice indeed – but it still looks weird.
> +    (version "1.6.0")
> +    (source
> +     (origin
> +       (method git-fetch)
> +       (uri (git-reference
> +             (url "https://framagit.org/Gee/sosage")
> +             (commit (string-append "v" version))))
> +       (file-name (git-file-name name version))
> +       (sha256
> +        (base32
> "0xgk3r18aj9xvrrqr9qdrr6800hkv6lhfcnmm5z21g8kbfh9x4jm"))))
Note that the source contains bundled sources you might want to get rid
off.
> +    (build-system cmake-build-system)
> +    (arguments
> +     (list #:tests? #f ; no tests
> +           #:configure-flags
> +           #~(list
> +              (string-append "-DSOSAGE_DATA_FOLDER="
> +                             #$(this-package-input "superfluous-
> returnz-data")))))
Consider placing this in a location where (search-input-directory …) is
useful. 
> +    (inputs
> +     (list libyaml
> +           lz4
> +           sdl2
> +           sdl2-mixer-x
> +           sdl2-ttf
> +           superfluous-returnz-data))
> +    (synopsis "Superfluous Returnz")
> +    (description
> +     "The action takes place in Fochougny, a very quiet French
> village
> +where the billionaire Harpagon Lonion lives.
> +He regularly dresses up as Superfluous, a very useless superhero in
> such a
> +peaceful countryside...
> +
> +Helped by his assistant Sophie, who tries to somehow temper the
> enthusiasm
> +of her employer, he will try to put his hands on the mysterious
> apple thief
> +who terrorizes the orchards of Fochougny...")
I'd personally avoid ellipses here and possibly shorten this a bit.
> +    (home-page
> "https://studios.ptilouk.net/superfluous-returnz/floss/")
I think it's fair to drop the /floss.
> +    (license license:expat)))
> +
Cheers
diff mbox series

Patch

diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 2ebd858ad6..c922029427 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -2934,6 +2934,46 @@  (define-public superfluous-returnz-data
     (home-page "https://studios.ptilouk.net/superfluous-returnz/floss/")
     (license license:cc-by-sa4.0)))
 
+(define-public superfluous-returnz
+  (package
+    (name "superfluous-returnz")
+    (version "1.6.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://framagit.org/Gee/sosage")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0xgk3r18aj9xvrrqr9qdrr6800hkv6lhfcnmm5z21g8kbfh9x4jm"))))
+    (build-system cmake-build-system)
+    (arguments
+     (list #:tests? #f ; no tests
+           #:configure-flags
+           #~(list
+              (string-append "-DSOSAGE_DATA_FOLDER="
+                             #$(this-package-input "superfluous-returnz-data")))))
+    (inputs
+     (list libyaml
+           lz4
+           sdl2
+           sdl2-mixer-x
+           sdl2-ttf
+           superfluous-returnz-data))
+    (synopsis "Superfluous Returnz")
+    (description
+     "The action takes place in Fochougny, a very quiet French village
+where the billionaire Harpagon Lonion lives.
+He regularly dresses up as Superfluous, a very useless superhero in such a
+peaceful countryside...
+
+Helped by his assistant Sophie, who tries to somehow temper the enthusiasm
+of her employer, he will try to put his hands on the mysterious apple thief
+who terrorizes the orchards of Fochougny...")
+    (home-page "https://studios.ptilouk.net/superfluous-returnz/floss/")
+    (license license:expat)))
+
 (define-public superstarfighter
   (package
     (name "superstarfighter")