From 5f084687013d82376c6423748c6558dc92690a98 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Pierre-Henry=20Fr=C3=B6hring?= <contact@phfrohring.com>
Date: Mon, 8 Aug 2022 10:24:05 +0200
Subject: [PATCH] gnu: Add emacs-mini-frame.
* gnu/packages/emacs-xyz.scm (emacs-mini-frame): New variable.
---
gnu/packages/emacs-xyz.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)
@@ -31967,3 +31967,30 @@ (define-public emacs-vundo
tree to go back to previous buffer states. To use vundo, type @kbd{M-x vundo RET} in
the buffer you want to undo. An undo tree buffer should pop up.")
(license license:gpl3+)))
+
+(define-public emacs-mini-frame
+ (let ((commit "60838f3cab438dcbda8eaa15ab3e5d1af88910e9")
+ (revision "0"))
+ (package
+ (name "emacs-mini-frame")
+ (version (git-version "1.19" revision commit))
+ (source
+ (origin
+ (uri (git-reference
+ (url "https://github.com/muffinmad/emacs-mini-frame.git")
+ (commit commit)))
+ (method git-fetch)
+ (sha256
+ (base32 "0q01iymz657bg3mcmq7vcl8r0ypsa1pqj1p6gxs7ywx1d33lan4d"))
+ (file-name (git-file-name name version))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/muffinmad/emacs-mini-frame")
+ (synopsis "Show minibuffer in child frame")
+ (description
+ "Place minibuffer at the top of the current frame on read-from-minibuffer.
+
+@dfn{mini-frame-mode} makes an advice around read-from-minibuffer function to
+create and show minibuffer-only child frame to accept input. @code{find-file}
+and similar functions associated mini-buffers may appear at the center of the
+screen and not at the bottom.")
+ (license license:gpl3+))))
--
2.37.1