diff mbox series

[bug#66573,v2,03/11] gnu: slurm: Add 23.02.6.

Message ID 3bf0382921f402ca595b61ec22ef980030cdf5a6.1697744099.git.ludo@gnu.org
State New
Headers show
Series None | expand

Commit Message

Ludovic Courtès Oct. 19, 2023, 7:36 p.m. UTC
From: Ludovic Courtès <ludovic.courtes@inria.fr>

* gnu/packages/parallel.scm (slurm): Update to 23.02.6.
(slurm-22.05): New variable.
---
 gnu/packages/parallel.scm | 20 +++++++++++++++++---
 1 file changed, 17 insertions(+), 3 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/parallel.scm b/gnu/packages/parallel.scm
index df7b498d1f..b014a404a6 100644
--- a/gnu/packages/parallel.scm
+++ b/gnu/packages/parallel.scm
@@ -9,7 +9,7 @@ 
 ;;; Copyright © 2017, 2018 Rutger Helling <rhelling@mykolab.com>
 ;;; Copyright © 2018–2022 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2018 Clément Lassieur <clement@lassieur.org>
-;;; Copyright © 2019-2022 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2019-2023 Ludovic Courtès <ludo@gnu.org>
 ;;; Copyright © 2020 Roel Janssen <roel@gnu.org>
 ;;; Copyright © 2021 Stefan Reichör <stefan@xsteve.at>
 ;;;
@@ -185,7 +185,7 @@  (define-public xjobs
 (define-public slurm
   (package
     (name "slurm")
-    (version "22.05.1")
+    (version "23.02.6")
     (source (origin
               (method url-fetch)
               (uri (string-append
@@ -193,7 +193,7 @@  (define-public slurm
                     version ".tar.bz2"))
               (sha256
                (base32
-                "0f3hhlki8g7slllsnyj1qikbsvr62i0hig85lcdcfnmsagzlhbyi"))
+                "08rz3r1rlnb3pmfdnbh542gm44ja0fdy8rkj4vm4lclc48cvqp2a"))
               (modules '((guix build utils)))
               (snippet
                '(begin
@@ -281,6 +281,20 @@  (define-public slurm
 ;; As noted in the link, YY.MM is the release scheme, and the 'maintenance'
 ;; digit does not introduce incompatibilities.
 
+(define-public slurm-22.05
+  (package
+    (inherit slurm)
+    (version "22.05.1")
+    (source (origin
+              (inherit (package-source slurm))
+              (method url-fetch)
+              (uri (string-append
+                    "https://download.schedmd.com/slurm/slurm-"
+                    version ".tar.bz2"))
+              (sha256
+               (base32
+                "0f3hhlki8g7slllsnyj1qikbsvr62i0hig85lcdcfnmsagzlhbyi"))))))
+
 (define-public slurm-21.08
   (package
     (inherit slurm)