diff mbox series

[bug#39785] Add lv2lint.

Message ID 3bc6eaeec9c24165f641bb89532707125f48ec4c.camel@zrythm.org
State Accepted
Headers show
Series [bug#39785] Add lv2lint. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Alexandros Theodotou Feb. 25, 2020, 3:14 p.m. UTC
Hi,

This patch adds lv2lint, an LV2 plugin lint tool used by plugin authors
during development/tests.

Thanks,
Alex

Comments

Leo Famulari March 15, 2020, 7:15 p.m. UTC | #1
> From a31f4f7e9ce1cdbc1cde5cc6da9859e1027680eb Mon Sep 17 00:00:00 2001
> From: Alexandros Theodotou <alex@zrythm.org>
> Date: Tue, 25 Feb 2020 15:11:29 +0000
> Subject: [PATCH] gnu: Add lv2lint.
> 
> * gnu/packages/audio.scm (lv2lint): New variable.

Thanks! Pushed as 70d9ef51392e9f8b33af4a7dea459eedd2ca738b after
importing the elf module (required for libelf) and removing git and lv2
from native-inputs, since they did not seem to be used.
diff mbox series

Patch

From a31f4f7e9ce1cdbc1cde5cc6da9859e1027680eb Mon Sep 17 00:00:00 2001
From: Alexandros Theodotou <alex@zrythm.org>
Date: Tue, 25 Feb 2020 15:11:29 +0000
Subject: [PATCH] gnu: Add lv2lint.

* gnu/packages/audio.scm (lv2lint): New variable.
---
 gnu/packages/audio.scm | 34 ++++++++++++++++++++++++++++++++++
 1 file changed, 34 insertions(+)

diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 5b8c610882..5be14f3859 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -4036,3 +4036,37 @@  libsamplerate for reading and resampling audio files, based on Robin Gareus'
 @code{audio_decoder} code.")
    (home-page "https://git.zrythm.org/cgit/libaudec")
    (license license:agpl3+)))
+
+(define-public lv2lint
+  (package
+    (name "lv2lint")
+    (version "0.4.0")
+    (source
+      (origin
+        (method git-fetch)
+        (uri (git-reference
+               (url "https://git.open-music-kontrollers.ch/lv2/lv2lint")
+               (commit version)))
+        (file-name (git-file-name name version))
+        (sha256
+          (base32
+            "1pspwqpzl2dw1hd9ra9yr53arqbbqjn7d7j0f7p9g3iqa76vblpi"))))
+    (build-system meson-build-system)
+    (arguments
+     `(#:configure-flags
+       `("-Delf-tests=true" ; for checking symbol visibility
+         "-Donline-tests=true"))) ; for checking URI existence
+    (inputs
+      `(("curl", curl)
+        ("libelf", libelf)
+        ("lilv", lilv)))
+    (native-inputs
+      `(("pkg-config", pkg-config)
+        ("git", git)
+        ("lv2", lv2)))
+    (synopsis "LV2 plugin lint tool")
+    (description "lv2lint is an LV2 lint-like tool that checks whether a
+given plugin and its UI(s) match up with the provided metadata and adhere
+to well-known best practices.")
+    (home-page "https://open-music-kontrollers.ch/lv2/lv2lint/")
+    (license license:artistic2.0)))
-- 
2.25.1