diff mbox series

[bug#40470] gnu: Add tap-lv2.

Message ID 3ba843afdbaffde3e3ad49d87de38d6dd39f4e86.camel@zrythm.org
State Accepted
Headers show
Series [bug#40470] gnu: Add tap-lv2. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Alexandros Theodotou April 6, 2020, 9:15 p.m. UTC
Hi Leo,

Thanks for the review.

Attaching the updated patch.

Thanks,
Alex

On Mon, 2020-04-06 at 15:02 -0400, Leo Famulari wrote:
> On Mon, Apr 06, 2020 at 04:04:49PM +0100, Alexandros Theodotou wrote:
> > Hi,
> > 
> > This patch adds tap-lv2, an LV2 port of the TAP LADSPA plugins. I
> > used
> > the date as a version because there was no tag.
> 
> Can you revise the version number stuff based on the guidelines in
> the
> manual section Version Numbers?
> 
> https://guix.gnu.org/manual/en/html_node/Version-Numbers.html#Version-Numbers
> 
> Otherwise LGTM

Comments

Leo Famulari April 7, 2020, 6:18 p.m. UTC | #1
On Mon, Apr 06, 2020 at 10:15:40PM +0100, Alexandros Theodotou wrote:
> * gnu/packages/music.scm (tap-lv2): new variable.

Thanks for the revised patch!

> +      (home-page "http://tap-plugins.sf.net/")

I amended this link based on feedback from `guix lint`; it permanently
redirects somewhere else.

I also noticed that we could puth INSTALL_PATH in #:make-flags and not
have to replace the 'install' phase, but I didn't make that change.

Pushed as 2aaf76582d0371127a51a4e112a4d9ff5a30dd37
diff mbox series

Patch

From e0945571b911085e7dae599a3657e2ed47837f7e Mon Sep 17 00:00:00 2001
From: Alexandros Theodotou <alex@zrythm.org>
Date: Mon, 6 Apr 2020 22:14:47 +0100
Subject: [PATCH] gnu: Add tap-lv2.

* gnu/packages/music.scm (tap-lv2): new variable.
---
 gnu/packages/music.scm | 42 ++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 42 insertions(+)

diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index ee402bad4d..f8751cf984 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -5380,3 +5380,45 @@  filtered, pitch shifted and ultimately disintegrated.  This is an unofficial
 port of the Regrader plugin created by Igorski.  It is available as an LV2
 plugin and a standalone JACK application.")
     (license license:expat)))
+
+(define-public tap-lv2
+  (let ((commit "cab6e0dfb2ce20e4ad34b067d1281ec0b193598a")
+        (revision "1"))
+    (package
+      (name "tap-lv2")
+      (version (git-version "0.0" revision commit))
+      (source
+        (origin
+          (method git-fetch)
+          (uri (git-reference
+                 (url "https://github.com/moddevices/tap-lv2.git")
+                 (commit commit)))
+          (file-name (git-file-name name version))
+          (sha256
+            (base32
+              "0q480djfqd9g8mzrggc4vl7yclrhdjqx563ghs8mvi2qq8liycw3"))))
+      (build-system gnu-build-system)
+      (arguments
+       `(#:tests? #f                      ; no check target
+         #:make-flags
+         (list "CC=gcc")
+         #:phases
+         (modify-phases %standard-phases
+           (delete 'configure) ; no configure
+           (replace 'install
+             (lambda _
+               (invoke "make"
+               (string-append "INSTALL_PATH="
+                              (assoc-ref %outputs "out")
+                              "/lib/lv2")
+                       "install"))))))
+      (inputs
+        `(("lv2", lv2)))
+      (native-inputs
+        `(("pkg-config", pkg-config)))
+      (synopsis "Audio plugin collection")
+      (description "TAP (Tom's Audio Processing) plugins is a collection of
+  audio effect plugins originally released as LADSPA plugins.  This package
+  offers an LV2 version ported by moddevices.")
+      (home-page "http://tap-plugins.sf.net/")
+      (license license:gpl2))))
-- 
2.26.0