diff mbox series

[bug#38744] adding copyq 3.9.3 to xdisorg.scm

Message ID 3ba0f830-f7d1-3301-a1a6-99a045735dd0@moncourriel.eu
State Accepted
Headers show
Series [bug#38744] adding copyq 3.9.3 to xdisorg.scm | expand

Commit Message

Thierry Dec. 25, 2019, 9:07 p.m. UTC

Comments

Efraim Flashner Dec. 26, 2019, 6:56 a.m. UTC | #1
Thank you for your patch! A couple of comments inline.

On Wed, Dec 25, 2019 at 10:07:24PM +0100, Thierry wrote:
> 

> From 3e5fb3f5fc852b0f512b6771c6950f4947f66dd7 Mon Sep 17 00:00:00 2001
> From: Grillon <thierry@moncourriel.eu>
> Date: Wed, 25 Dec 2019 21:22:42 +0100
> Subject: [PATCH] gnu: copyq(clipboard manager): added v3.9.3
> 
> * gnu/packages/xdisorg.scm (copyq): added from 3.9.3
> ---
>  gnu/packages/xdisorg.scm | 29 +++++++++++++++++++++++++++++
>  1 file changed, 29 insertions(+)
> 
> diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
> index b1759eabb2..9ee713de2f 100644
> --- a/gnu/packages/xdisorg.scm
> +++ b/gnu/packages/xdisorg.scm
> @@ -85,6 +85,7 @@
>    #:use-module (gnu packages guile)
>    #:use-module (gnu packages xml)
>    #:use-module (gnu packages gtk)
> +  #:use-module (gnu packages qt)
>    #:use-module (gnu packages xorg)
>    #:use-module (gnu packages fontutils)
>    #:use-module (gnu packages bison)
> @@ -229,6 +230,34 @@ with X11 or Wayland, or in a text terminal with ncurses.")
>      (license (list license:gpl3+        ; client program[s] and other sources
>                     license:lgpl3+))))   ; library and bindings
>  
> +(define-public copyq
> +(package
> +  (name "copyq")
> +  (version "3.9.3")
> +  (source (origin
> +            (method url-fetch)
> +            (uri (string-append "https://github.com/hluk/CopyQ/archive/v" version
> +                                ".tar.gz"))

tarballs from github with the '/archive/' string are autogenerated and
can be regenerated in the future, leading to a hash mismatch. I checked
the release page and it looks like our best option is to use the .zip
file. (This also means you'll need to add unzip to native-inputs)

> +            (sha256
> +             (base32
> +              "154yccvlyhr6dml29cvkaqi8277vshmpydvy6ar125qm74q2rib5"))))
> +  (build-system cmake-build-system)
> +  (arguments
> +    `(#:configure-flags '("-DCMAKE_BUILD_TYPE=Release")
> +      #:tests? #f))

Are there no tests or can the test suite not be run? Please leave a note :)

> +  (inputs `(("qtbase" ,qtbase)
> +            ("qtx11extras" ,qtx11extras)
> +            ("qtsvg" ,qtsvg)
> +            ("qtscript" ,qtscript)))
> +  (synopsis "Good qt clipboard manager")

Go ahead and change this to something else. Checking the repo I'd go
with "Clipboard manager with advanced features".

> +  (description "CopyQ is clipboard manager –
> +    a desktop application which stores content of the system clipboard
> +    whenever it changes and allows to search the history
> +    and copy it back to the system clipboard
> +    or paste it directly to other applications.")

Unfortunately the description reads to me like bad poetry :p I copied
some text from the repo and re-wrapped it below:

    (description "CopyQ is clipboard manager with editing and scripting
features.  CopyQ monitors system clipboard and saves its content in customized
tabs.  Saved clipboard can be later copied and pasted directly into any
application.)

> +  (home-page "https://hluk.github.io/CopyQ/")
> +  (license license:gpl3+)))
> +
>  (define-public xclip
>    (package
>      (name "xclip")
> -- 
> 2.24.1
>
Efraim Flashner Dec. 28, 2019, 8:31 p.m. UTC | #2
Patch pushed with discussed changes.
diff mbox series

Patch

From 3e5fb3f5fc852b0f512b6771c6950f4947f66dd7 Mon Sep 17 00:00:00 2001
From: Grillon <thierry@moncourriel.eu>
Date: Wed, 25 Dec 2019 21:22:42 +0100
Subject: [PATCH] gnu: copyq(clipboard manager): added v3.9.3

* gnu/packages/xdisorg.scm (copyq): added from 3.9.3
---
 gnu/packages/xdisorg.scm | 29 +++++++++++++++++++++++++++++
 1 file changed, 29 insertions(+)

diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index b1759eabb2..9ee713de2f 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -85,6 +85,7 @@ 
   #:use-module (gnu packages guile)
   #:use-module (gnu packages xml)
   #:use-module (gnu packages gtk)
+  #:use-module (gnu packages qt)
   #:use-module (gnu packages xorg)
   #:use-module (gnu packages fontutils)
   #:use-module (gnu packages bison)
@@ -229,6 +230,34 @@  with X11 or Wayland, or in a text terminal with ncurses.")
     (license (list license:gpl3+        ; client program[s] and other sources
                    license:lgpl3+))))   ; library and bindings
 
+(define-public copyq
+(package
+  (name "copyq")
+  (version "3.9.3")
+  (source (origin
+            (method url-fetch)
+            (uri (string-append "https://github.com/hluk/CopyQ/archive/v" version
+                                ".tar.gz"))
+            (sha256
+             (base32
+              "154yccvlyhr6dml29cvkaqi8277vshmpydvy6ar125qm74q2rib5"))))
+  (build-system cmake-build-system)
+  (arguments
+    `(#:configure-flags '("-DCMAKE_BUILD_TYPE=Release")
+      #:tests? #f))
+  (inputs `(("qtbase" ,qtbase)
+            ("qtx11extras" ,qtx11extras)
+            ("qtsvg" ,qtsvg)
+            ("qtscript" ,qtscript)))
+  (synopsis "Good qt clipboard manager")
+  (description "CopyQ is clipboard manager –
+    a desktop application which stores content of the system clipboard
+    whenever it changes and allows to search the history
+    and copy it back to the system clipboard
+    or paste it directly to other applications.")
+  (home-page "https://hluk.github.io/CopyQ/")
+  (license license:gpl3+)))
+
 (define-public xclip
   (package
     (name "xclip")
-- 
2.24.1