[bug#76071,v1] gnu: Add astroterm.
Commit Message
From: Vasilii Smirnov <vasilii.smirnov@mailbox.org>
* gnu/packages/astronomy.scm (astroterm): New variable.
Change-Id: Ie724bbfc238bee4a1603f5dbff9bc734ec65ff3e
---
gnu/packages/astronomy.scm | 51 ++++++++++++++++++++++++++++++++++++++
1 file changed, 51 insertions(+)
base-commit: 216a37ba5005148bbb88c4f6b8e9dd5904d49074
@@ -78,6 +78,7 @@ (define-module (gnu packages astronomy)
#:use-module (gnu packages photo)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages plotutils)
+ #:use-module (gnu packages popt)
#:use-module (gnu packages pretty-print)
#:use-module (gnu packages python)
#:use-module (gnu packages python-build)
@@ -97,6 +98,7 @@ (define-module (gnu packages astronomy)
#:use-module (gnu packages tls)
#:use-module (gnu packages version-control)
#:use-module (gnu packages video)
+ #:use-module (gnu packages vim)
#:use-module (gnu packages web)
#:use-module (gnu packages wxwidgets)
#:use-module (gnu packages xiph)
@@ -260,6 +262,55 @@ (define-public aoflagger
wide set of telescopes.")
(license license:gpl3+)))
+(define-public astroterm
+ (package
+ (name "astroterm")
+ (version "1.0.7")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/da-luce/astroterm")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "03vfjcf8y039xbkigc3wy1sccbmk7zyy2nkfp984nbdxgr1pj129"))))
+ (build-system meson-build-system)
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'configure 'copy-bsc5
+ (lambda _
+ (copy-file #+(this-package-native-input "bsc5")
+ "./data/bsc5")))
+ (add-before 'configure 'fix-embed-sh-ref
+ (lambda _
+ (substitute* "meson.build"
+ (("'../scripts/embed.sh'")
+ "meson.source_root() / 'scripts/embed.sh'")))))))
+ (native-inputs
+ `(("bsc5"
+ ,(origin
+ (method url-fetch)
+ (uri (string-append
+ "https://web.archive.org/web/20250114214121/"
+ "http://tdc-www.harvard.edu/catalogs/BSC5"))
+ (sha256
+ (base32
+ "0h63ih62md0y99jwba59d1xrvfijck5s2ygq28fbdv2fmwpd0wg4"))))
+ ("pkg-config" ,pkg-config)
+ ("xxd" ,xxd)))
+ (inputs
+ (list ncurses argtable))
+ (home-page "https://github.com/da-luce/astroterm")
+ (synopsis "Planetarium for your terminal")
+ (description
+ "@code{astroterm} is a terminal-based star map written in C. It displays
+the real-time positions of stars, planets, constellations, and more, all
+within your terminal - no telescope required!")
+ (license license:expat)))
+
(define-public calceph
(package
(name "calceph")