diff mbox series

[bug#56041,v3] gnu: Add vkmark.

Message ID 3aecf31124b3b983409f112c9858e597@schwi.pl
State New
Headers show
Series [bug#56041,v3] gnu: Add vkmark. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Tomasz Jeneralczyk June 19, 2022, 3:46 p.m. UTC
* gnu/packages/benchmark.scm (vkmark): Add variable.
---
  gnu/packages/benchmark.scm | 48 ++++++++++++++++++++++++++++++++++++++
  1 file changed, 48 insertions(+)

  ;;;
@@ -36,6 +37,7 @@ (define-module (gnu packages benchmark)
    #:use-module (guix build-system cmake)
    #:use-module (guix build-system gnu)
    #:use-module (guix build-system python)
+  #:use-module (guix build-system meson)
    #:use-module (gnu packages)
    #:use-module (gnu packages autotools)
    #:use-module (gnu packages base)
@@ -45,6 +47,9 @@ (define-module (gnu packages benchmark)
    #:use-module (gnu packages kde-frameworks)
    #:use-module (gnu packages databases)
    #:use-module (gnu packages docbook)
+  #:use-module (gnu packages freedesktop)
+  #:use-module (gnu packages gl)
+  #:use-module (gnu packages graphics)
    #:use-module (gnu packages linux)
    #:use-module (gnu packages lua)
    #:use-module (gnu packages maths)
@@ -57,6 +62,8 @@ (define-module (gnu packages benchmark)
    #:use-module (gnu packages python-web)
    #:use-module (gnu packages python-xyz)
    #:use-module (gnu packages qt)
+  #:use-module (gnu packages vulkan)
+  #:use-module (gnu packages xorg)
    #:use-module (gnu packages xml)
    #:use-module (ice-9 match))

@@ -584,3 +591,44 @@ (define-public sysbench
  @item
  @end itemize")
      (license license:gpl2+)))
+
+(define-public vkmark
+  ;; The latest "release" of vkmark is tagged "2017.08" and it's so old
+  ;; I couldn't even compile it. The current master branch's head
+  ;; seems to be working just fine.
+  (let ((commit "d872846e2e7c47010c11227eb713d00ccfdd35c6")
+        (revision "1"))
+    (package
+      (name "vkmark")
+      (version (git-version "2017.08" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/vkmark/vkmark")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  
"0zlryz8i8jvl160bv30ig5nd9h4ahpjfw53ys839i41xi80jjg5d"))))
+      (build-system meson-build-system)
+      (native-inputs (list pkg-config))
+      ;; The kms back-end, as it is, seems to have bitrot
+      ;; and would need maintenance to work with current Mesa:
+      ;; https://gitlab.freedesktop.org/mesa/mesa/-/commit/5e6db1916806
+      (inputs (list vulkan-loader
+                    vulkan-headers
+                    glm
+                    assimp
+                    libxcb
+                    xcb-util-wm
+                    wayland-protocols
+                    wayland))
+      (synopsis "Extensible benchmarking suite for Vulkan")
+      (description
+       "
+vkmark offers a suite of scenes that can be used to measure various 
aspects of Vulkan
+performance.  The way in which each scene is rendered is configurable 
through a set of
+options.  To list the available scenes and their acceptable options you 
can use the
+-l, --list-scenes command line option.")
+      (home-page "https://github.com/vkmark/vkmark")
+      (license license:lgpl2.1+))))

base-commit: 319b8331b2357e12ec9edb9665513c32bef56622
diff mbox series

Patch

diff --git a/gnu/packages/benchmark.scm b/gnu/packages/benchmark.scm
index b167c6de6e..1ca2c4cbfa 100644
--- a/gnu/packages/benchmark.scm
+++ b/gnu/packages/benchmark.scm
@@ -11,6 +11,7 @@ 
  ;;; Copyright © 2020, 2021, 2022 Maxim Cournoyer 
<maxim.cournoyer@gmail.com>
  ;;; Copyright © 2020 Greg Hogan <code@greghogan.com>
  ;;; Copyright © 2021 Arun Isaac <arunisaac@systemreboot.net>
+;;; Copyright © 2022 Tomasz Jeneralczyk <tj@schwi.pl>
  ;;;
  ;;; This file is part of GNU Guix.