[bug#77714,4/6] gnu: Remove emacs-casual-lib.
Commit Message
From: Peter Polidoro <peter@polidoro.io>
* gnu/packages/emacs-xyz.scm (emacs-casual-lib): Delete variable.
Change-Id: Ic8e81273eee297d24c88d1d8c2fefebd9c449440
---
gnu/packages/emacs-xyz.scm | 31 -------------------------------
1 file changed, 31 deletions(-)
@@ -35632,37 +35632,6 @@ (define-public emacs-casual-avy
"Casual Avy is an opinionated Transient-based porcelain for Emacs Avy.")
(license license:gpl3+)))
-(define-public emacs-casual-lib
- (package
- (name "emacs-casual-lib")
- (version "2.0.0")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/kickingvegas/casual-lib")
- (commit version)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1hmr0zzwm3f88786j8p8x39jn5b8jja37x1iww4vd83dsvkksbpa"))))
- (build-system emacs-build-system)
- (arguments
- (list #:tests? #t
- #:test-command #~(list "make" "tests")
- #:phases
- #~(modify-phases %standard-phases
- (add-after 'unpack 'move-source-files
- (lambda _
- (let ((el-files (find-files "./lisp" ".*\\.el$")))
- (for-each (lambda (f) (copy-file f (basename f)))
- el-files)))))))
- (native-inputs (list python-minimal))
- (home-page "https://github.com/kickingvegas/casual-lib")
- (synopsis "Library package for the Emacs Casual porcelains")
- (description
- "Casual Lib is a library package used to support the Casual porcelains.")
- (license license:gpl3+)))
-
(define-public emacs-calibredb
(package
(name "emacs-calibredb")