diff mbox series

[bug#72219,18/34] gnu: python-pytest-openfiles: Simplify package.

Message ID 3a3ec20af8809309ced91febedfa894ea7c456f3.1721514686.git.sharlatanus@gmail.com
State New
Headers show
Series Astronomy update 2024/07 | expand

Commit Message

Sharlatan Hellseher July 20, 2024, 10:40 p.m. UTC
* gnu/packages/python-check.scm (python-pytest-openfiles)
[build-system]: Swap to pyproject-build-system.
[arguments]: <#:phases>: Use default 'chck phase.

Change-Id: I3bbbacd8694afdfee020f11d37f5c035bdad73f9
---
 gnu/packages/python-check.scm | 10 +---------
 1 file changed, 1 insertion(+), 9 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index b6e401b443..74e833686f 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -847,15 +847,7 @@  (define-public python-pytest-openfiles
        (uri (pypi-uri "pytest_openfiles" version))
        (sha256
         (base32 "14x9f1l9a5ghf527i5qfcfa003mkrky1dhx2hfwq5nma9v1n0lgz"))))
-    (build-system python-build-system)
-    (arguments
-     '(#:phases
-       (modify-phases %standard-phases
-         (replace 'check
-           (lambda* (#:key inputs outputs #:allow-other-keys)
-             ;; Make the installed plugin discoverable by Pytest.
-             (add-installed-pythonpath inputs outputs)
-             (invoke "pytest" "-vv"))))))
+    (build-system pyproject-build-system)
     (native-inputs
      (list python-setuptools-scm python-pytest))
     (propagated-inputs