diff mbox series

[bug#71910] gnu: Add emacs-eshell-git-prompt.

Message ID 3a11fc4804f3b1fe372031b7580ec8beaa405f17.1719982934.git.public@thanosapollo.org
State New
Headers show
Series [bug#71910] gnu: Add emacs-eshell-git-prompt. | expand

Commit Message

Thanos Apollo July 3, 2024, 5:02 a.m. UTC
gnu/packages/emacs-xyz.scm (emacs-eshell-git-prompt): New variable.

Change-Id: If3e7f918708d9b57295b368f5d7c5fc7b18d73cf
---
 gnu/packages/emacs-xyz.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)


base-commit: 972c06dc79641864b05590b2cd905cc8b810062b
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 76cd340e5e..c82e264930 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -35182,6 +35182,28 @@  (define-public emacs-eshell-did-you-mean
 commands that bear resemblance to the input command.")
     (license license:gpl3+)))
 
+(define-public emacs-eshell-git-prompt
+  (let ((commit "dfcf9cd93add6763e2c46603b0323274d4c22906"))
+    (package
+      (name "emacs-eshell-git-prompt")
+      (version "0.1.3")
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/xuchunyang/eshell-git-prompt")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "13b7nr0819pgzyvh0szi0zjyazgpxmsbqcz65cccyhh2pq48zb7j"))))
+      (build-system emacs-build-system)
+      (propagated-inputs
+       (list emacs-dash))
+      (home-page "https://github.com/xuchunyang/eshell-git-prompt")
+      (synopsis "Themes for Emacs Shell (Eshell) prompt.")
+      (description "This package provides a variety of themes for Emacs Shell (Eshell) prompt.")
+      (license license:gpl3+))))
+
 (define-public emacs-unfill
   (package
     (name "emacs-unfill")