diff mbox series

[bug#70256,v3] gnu: signon-plugin-oauth2: Fix installing in a doubled prefix.

Message ID 39f79b5440b54301d610ec1240a8ad5e3bef3e71.1712495595.git.sughosha@disroot.org
State New
Headers show
Series [bug#70256,v3] gnu: signon-plugin-oauth2: Fix installing in a doubled prefix. | expand

Commit Message

Sughosha April 7, 2024, 1:13 p.m. UTC
This commit fixes creating one more /gnu/store/ directory inside its
own prefix, creating again the same prefix inside it and then
installing in it.

* gnu/packages/qt.scm (signon-plugin-oauth2)[arguments]:
<#:make-flags>: Remove argument.
<#:phases>: In configure phase, add SIGNON_PLUGINS_DIR variable.

Change-Id: Ie7694690c320a95fd9bcc02cb39cd64007f0e979
---
 gnu/packages/qt.scm | 5 +++--
 1 file changed, 3 insertions(+), 2 deletions(-)


base-commit: 188d18fc47f0d38edfe06e3e5834fa8587bd300b

Comments

Christopher Baines April 15, 2024, 9:34 a.m. UTC | #1
Sughosha via Guix-patches via <guix-patches@gnu.org> writes:

> This commit fixes creating one more /gnu/store/ directory inside its
> own prefix, creating again the same prefix inside it and then
> installing in it.
>
> * gnu/packages/qt.scm (signon-plugin-oauth2)[arguments]:
> <#:make-flags>: Remove argument.
> <#:phases>: In configure phase, add SIGNON_PLUGINS_DIR variable.
>
> Change-Id: Ie7694690c320a95fd9bcc02cb39cd64007f0e979
> ---
>  gnu/packages/qt.scm | 5 +++--
>  1 file changed, 3 insertions(+), 2 deletions(-)

Looks good to me, I've pushed this to master as
8a257582e3366b37ab7651198fc4c8912c520b37.

Chris
diff mbox series

Patch

diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 1440c6981c..4a4f6b285d 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -5327,7 +5327,6 @@  (define-public signon-plugin-oauth2
     (inputs (list signond))
     (arguments
      (list #:tests? #f                  ;no tests
-           #:make-flags #~(list (string-append "INSTALL_ROOT=" #$output))
            #:phases
            #~(modify-phases %standard-phases
                (replace 'configure
@@ -5337,7 +5336,9 @@  (define-public signon-plugin-oauth2
                       ""))
                    (invoke "qmake"
                            (string-append "PREFIX=" #$output)
-                           (string-append "LIBDIR=" #$output "/lib")))))))
+                           (string-append "LIBDIR=" #$output "/lib")
+                           (string-append "SIGNON_PLUGINS_DIR=" #$output
+                                          "/lib/signon")))))))
     (synopsis "OAuth 2 plugin for signon")
     (description
      "This plugin for the Accounts-SSO SignOn daemon handles the OAuth