[bug#62640,v3] gnu: Add pmbootstrap.

Message ID 39f24b984cbc74b14a859046f3c466f295276738.1747654181.git.herman@rimm.ee
State New
Headers
Series [bug#62640,v3] gnu: Add pmbootstrap. |

Commit Message

Herman Rimm May 19, 2025, 11:42 a.m. UTC
  From: Sughosha <Sughosha@proton.me>

* gnu/packages/postmarketos.scm: New file.
* gnu/packages/local.mk (GNU_SYSTEM_MODULES): Register file.

Change-Id: Ib8347dd536738d2ea16a961c85308a0e43b98c1f
---
Hello,

For v3:
version is bumped to 3.4.0;
source uses git-fetch;
three tests are skipped;
mkbootimg, python-setuptools, python-wheel and util-linux are added to
native-inputs;
multipath-tools is added to propagated-inputs.

pmbootstrap uses kpartx from multipath-tools for e.g.:
$ pmbootstrap install --sdcard /dev/sda
If the kpartx invocations could be replaced with a store path,
then multipath-tools could be moved to (normal) inputs.

Cheers,
Herman

 gnu/local.mk                  |  3 +-
 gnu/packages/postmarketos.scm | 71 +++++++++++++++++++++++++++++++++++
 2 files changed, 73 insertions(+), 1 deletion(-)
 create mode 100644 gnu/packages/postmarketos.scm


base-commit: 450a361532573a02389530a6a80b7821683ed41b
  

Patch

diff --git a/gnu/local.mk b/gnu/local.mk
index 3730d272eae..c4d5e6cb2e4 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -566,7 +566,8 @@  GNU_SYSTEM_MODULES =				\
   %D%/packages/poedit.scm				\
   %D%/packages/polkit.scm			\
   %D%/packages/popt.scm				\
-  %D%/packages/potassco.scm				\
+  %D%/packages/postmarketos.scm			\
+  %D%/packages/potassco.scm			\
   %D%/packages/power.scm			\
   %D%/packages/printers.scm			\
   %D%/packages/profiling.scm			\
diff --git a/gnu/packages/postmarketos.scm b/gnu/packages/postmarketos.scm
new file mode 100644
index 00000000000..78e95fcbb5d
--- /dev/null
+++ b/gnu/packages/postmarketos.scm
@@ -0,0 +1,71 @@ 
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2023 Sughosha <sughosha@proton.me>
+;;; Copyright © 2025 Herman Rimm <herman@rimm.ee>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages postmarketos)
+  #:use-module (gnu packages admin)
+  #:use-module (gnu packages android)
+  #:use-module (gnu packages bash)
+  #:use-module (gnu packages check)
+  #:use-module (gnu packages linux)
+  #:use-module (gnu packages python-build)
+  #:use-module (gnu packages tls)
+  #:use-module (gnu packages version-control)
+  #:use-module (guix build-system pyproject)
+  #:use-module (guix gexp)
+  #:use-module (guix git-download)
+  #:use-module ((guix licenses) #:prefix license:)
+  #:use-module (guix packages))
+
+(define-public pmbootstrap
+  (package
+    (name "pmbootstrap")
+    (version "3.4.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+              (url (string-append "https://gitlab.postmarketos.org/"
+                                  "postmarketOS/pmbootstrap"))
+              (commit version)))
+       (sha256
+        (base32 "16naj8ykipbrs2a93zaxci1wl045cc9jn7rq8sy76d1rqlqb9mmw"))))
+    (build-system pyproject-build-system)
+    (arguments
+     (list #:test-flags
+           ;; Tests require a pmaports git repository in the workdir.
+           #~(list (string-append "--deselect=test/core/test_pkgrepo.py"
+                                  "::test_pkgrepo_pmaports")
+                   (string-append "--deselect=test/parse/test_bootimg.py"
+                                  "::test_bootimg")
+                   ;; RuntimeError: No package repositories specified?
+                   (string-append "--deselect=test/parse/test_deviceinfo.py"
+                                  "::test_random_valid_deviceinfos"))))
+    (native-inputs (list mkbootimg
+                         python-pytest
+                         python-setuptools
+                         python-wheel
+                         util-linux)) ; for losetup
+    (inputs (list bash-minimal git openssl procps))
+    (propagated-inputs (list multipath-tools)) ; for kpartx
+    (home-page "https://gitlab.com/postmarketOS/pmbootstrap")
+    (synopsis "Bootstrap a postmarketOS system")
+    (description
+     "This package provides a sophisticated chroot, build and flash tool
+to develop and install postmarketOS.")
+    (license license:gpl3+)))