diff mbox series

[bug#67131,v3,6/7] gnu: Add python-pytmx.

Message ID 39a919be-0684-f528-c29e-e71647e2f813@disroot.org
State New
Headers show
Series [bug#67131,v3,1/7] gnu: Add python-neteria. | expand

Commit Message

Adam Faiz Dec. 18, 2023, 3:19 p.m. UTC
From c3f4e8eb98b1c0e802e80e1853476630feb7db6c Mon Sep 17 00:00:00 2001
Message-ID: <c3f4e8eb98b1c0e802e80e1853476630feb7db6c.1702911965.git.adam.faiz@disroot.org>
In-Reply-To: <9f6186753e6b9cd1f70ec11059c193d30db123aa.1702911964.git.adam.faiz@disroot.org>
References: <9f6186753e6b9cd1f70ec11059c193d30db123aa.1702911964.git.adam.faiz@disroot.org>
From: AwesomeAdam54321 <adam.faiz@disroot.org>
Date: Mon, 13 Nov 2023 11:43:51 +0800
Subject: [PATCH v3 6/7] gnu: Add python-pytmx.

* gnu/packages/game-development.scm (python-pytmx): New variable.
---
 gnu/packages/game-development.scm | 19 +++++++++++++++++++
 1 file changed, 19 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 5ee4b08e21..a2d7c5ea63 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -532,6 +532,25 @@  (define-public python-pyscroll
 for animated scrolling maps for your new or existing game.")
     (license license:lgpl3+)))
 
+(define-public python-pytmx
+  (package
+    (name "python-pytmx")
+    (version "3.32")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "PyTMX" version))
+              (sha256
+               (base32
+                "1jh9b0pjqbjdv72v5047p5d769ic084g013njvky0zcfiwrxi3w5"))))
+    (build-system python-build-system)
+    (propagated-inputs
+     (list python-pygame python-pysdl2 python-pyglet))
+  (home-page "https://github.com/bitcraft/PyTMX")
+  (synopsis "Python library to read Tiled Map Editor's TMX maps")
+  (description "@code{pytmx} is a map loader for python/pygame designed for games.
+It provides smart tile loading with a fast and efficient storage base.")
+  (license license:lgpl3+)))
+
 (define-public python-tmx
   (package
     (name "python-tmx")