diff mbox series

[bug#53765,v4,1/2] gnu: clojure-tools-deps-alpha: Patch unpackageable

Message ID 3981f1dd891e8cd863dc9fecffe30c97235ce643.1650150000.git.mail@reilysiegel.com
State New
Headers show
Series Simpler patch removing warnings. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Reily Siegel April 16, 2022, 9:59 p.m. UTC
---
 gnu/packages/clojure.scm | 15 ++++++++-------
 1 file changed, 8 insertions(+), 7 deletions(-)

Comments

M April 17, 2022, 7:59 a.m. UTC | #1
Hi,

While you can choose to not include the library packages that were
eventually unused, you don't have to exclude them just because they are
-- they might be useful to other people or yourself, for non-clojure-
tools things, or for clojure-tools if(when?) Cognitect decides to make
the compiler free software.

Reily Siegel schreef op za 16-04-2022 om 23:59 [+0200]:
> ---
>  gnu/packages/clojure.scm | 15 ++++++++-------
>  1 file changed, 8 insertions(+), 7 deletions(-)
> 

Changelog message is missing, maybe:

* gnu/packages/clojure.scm (clojure-tools-deps-
alpha)[arguments]<#:phases>{remove-s3-transporter}: Remove warning that
is emitted even when S3 is unused.

> diff --git a/gnu/packages/clojure.scm b/gnu/packages/clojure.scm
> index e6eb749501..0d9e984bd6 100644
> --- a/gnu/packages/clojure.scm
> +++ b/gnu/packages/clojure.scm
> @@ -501,11 +501,11 @@ (define-public clojure-tools-deps-alpha
>         #:tests? #f
>         #:phases
>         (modify-phases %standard-phases
> -         ;; FIXME: Currently, the S3 transporter depends on ClojureScript,
> -         ;; which is very difficult to package due to dependencies on Java
> -         ;; libraries with non-standard build systems. Instead of actually
> -         ;; packaging these libraries, we just remove the S3 transporter that
> -         ;; depends on them.
> +         ;; Currently, the S3 transporter depends on com.cognitect.aws/s3,
> +         ;; which is built from Amazon's aws-sdk-js using a closed-source
> +         ;; script. For more information see:
> +         ;; https://issues.guix.gnu.org/53765
> +         ;; https://github.com/cognitect-labs/aws-api/issues/116

Guix (and more generally, GNU) is more a free software thing than an
open source thing, it requires the software it includes to be free
software but it doesn't seem to require it to be open-source (though in
practice they seem to describe the same software ...).

Also still looks like a FIXME to me, personally I'd keep the ‘FIXME:’
prefix.

> ---
> gnu/packages/clojure.scm | 3 ++-
> 1 file changed, 2 insertions(+), 1 deletion(-)

Likewise (about the commit message).  Possible example (from another
package):

* gnu/packages/web.scm (python-feedparser) [propagated-inputs]: Add
python-sgmllib3k.

Otherwise, LGTM, thanks.

Greetings,
Maxime.
Reily Siegel April 17, 2022, 11:33 a.m. UTC | #2
Maxime Devos <maximedevos@telenet.be> writes:

> Hi,
>
> While you can choose to not include the library packages that were
> eventually unused, you don't have to exclude them just because they are
> -- they might be useful to other people or yourself, for non-clojure-
> tools things, or for clojure-tools if(when?) Cognitect decides to make
> the compiler free software.

I will submit the other packages as separate patches, for the sake of
simplicity, as they are no longer needed for clojure-tools.

> Changelog message is missing, maybe:

I'm writing an emacs utility to format patches for email, thanks for
helping me find a bug! I will resubmit with commit messages.

> Also still looks like a FIXME to me, personally I'd keep the ‘FIXME:’
> prefix.

I will re-add the FIXME tag.
M April 17, 2022, 2:53 p.m. UTC | #3
Reily Siegel schreef op zo 17-04-2022 om 13:33 [+0200]:
> > Changelog message is missing, maybe:
> 
> I'm writing an emacs utility to format patches for email, thanks for
> helping me find a bug! I will resubmit with commit messages.

There's an ./etc/committer.scm script you can use, though it is a bit
limited.

Greetings,
Maxime.
diff mbox series

Patch

diff --git a/gnu/packages/clojure.scm b/gnu/packages/clojure.scm
index e6eb749501..0d9e984bd6 100644
--- a/gnu/packages/clojure.scm
+++ b/gnu/packages/clojure.scm
@@ -501,11 +501,11 @@  (define-public clojure-tools-deps-alpha
        #:tests? #f
        #:phases
        (modify-phases %standard-phases
-         ;; FIXME: Currently, the S3 transporter depends on ClojureScript,
-         ;; which is very difficult to package due to dependencies on Java
-         ;; libraries with non-standard build systems. Instead of actually
-         ;; packaging these libraries, we just remove the S3 transporter that
-         ;; depends on them.
+         ;; Currently, the S3 transporter depends on com.cognitect.aws/s3,
+         ;; which is built from Amazon's aws-sdk-js using a closed-source
+         ;; script. For more information see:
+         ;; https://issues.guix.gnu.org/53765
+         ;; https://github.com/cognitect-labs/aws-api/issues/116
          (add-after 'unpack 'remove-s3-transporter
            (lambda _
              (for-each delete-file
@@ -519,9 +519,10 @@  (define-public clojure-tools-deps-alpha
                         (string-append
                          "src/test/clojure/clojure/"
                          "tools/deps/alpha/util/test_s3_transporter.clj")))
-             (substitute*
-                 "src/main/clojure/clojure/tools/deps/alpha/util/maven.clj"
+             (substitute* "src/main/clojure/clojure/tools/deps/alpha/util/maven.clj"
                (("clojure.tools.deps.alpha.util.s3-transporter")
+                "")
+               (("(printerrln \"Warning: failed to load the S3TransporterFactory class\")")
                 "")))))))
     (propagated-inputs (list maven-resolver-api
                              maven-resolver-spi