diff mbox series

[bug#40485] Acknowledgement (gnu: Update libxfce4ui to 4.15.2.)

Message ID 39267250-afcc-1e79-db07-cd47756d0967@riseup.net
State Accepted
Headers show
Series [bug#40485] Acknowledgement (gnu: Update libxfce4ui to 4.15.2.) | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Naga Malleswari April 9, 2020, 8:42 p.m. UTC
Hi

Finally It worked......Submitting the patch for review.

Now xfce4-embed-plugin is building fine after i modified the input to
old version of libxfce4ui.

I referred the older commit message from help2man from the log. I am
still not sure about it.

Its the same code i have sent you. I used the origin block. And (name  
x) was the only difference.

On 09/04/20 3:49 am, Danny Milosavljevic wrote:
> + (inherit libxfce4ui-1)
> +    (name "libxfce4ui") ; not necessary but I like it for no reason
> +    (version "4.15.2")
> +    (source (origin ; necessary block!!
I used the same. I added name block. It worked !!!
> $ ./pre-inst-env guix build libxfce4ui@4.14.1
> /gnu/store/fk1ziblzyslg9z7gpm9j410jfgwbilsr-libxfce4ui-4.14.1
>
> $ ./pre-inst-env guix build libxfce4ui@4.15.2
> /gnu/store/cy5wyx1zrq9ahp6zl0wjpv0nd0a6hpkb-libxfce4ui-4.15.2

It worked the same.

1) If name block is removed in latest.   Its building the older version.
Why??

2)  /latest is also removed from variable. Would i make a difference?


> ewline)
>   (write (package-version b))
>   (newline)
Thanks for such a long explanation. It took a bit of time for me.
> package "b" would have: (name "b") and (version "b").
>
>     Guile variables are invisible to the end user of the "guix" tool.

Comments

Danny Milosavljevic April 9, 2020, 10:11 p.m. UTC | #1
Hi,

On Fri, 10 Apr 2020 02:12:42 +0530
Naga Malleswari <nagamalli@riseup.net> wrote:

>On 09/04/20 3:49 am, Danny Milosavljevic wrote:
>> + (inherit libxfce4ui-1)
>> +    (name "libxfce4ui") ; not necessary but I like it for no reason
>> +    (version "4.15.2")
>> +    (source (origin ; necessary block!!  

>I used the same. I added name block. It worked !!!

>1) If name block is removed in the latest [libxfce4ui package], it's building the
>older version. Why??

If I remove (name "libxfce4ui") from the latest libxfce4ui package, and then
invoke

  make -j5 SUBDIRS=

then I get an error

  error: name: unbound variable.

from the compilation of gnu/packages/xfce.scm.
So that's why the latest libxfce4ui package would never be loaded into guix
(it's broken) and instead the other one would be used.

I'm not sure why that is the case.  It's certainly different to most other
programming languages.  @Ludo?

@Ludo: Reduced test case:

  ,use (guix packages)
  (define-public a
    (package
      (name "a")
      (version name)
      (source #f) (build-system #f) (synopsis #f) (description #f) (license #f) (home-page #f)))

  (define-public b
    (package
      (inherit a)
      (version name))) ; error message here

Error message:

  ;;; <stdin>:9:4: warning: possibly unbound variable `name'
  <unnamed port>:9:4: In procedure module-lookup: Unbound variable: name

What's happening here?  I would have expected NAME to be available from the
descendant record and accessing the ancestor record... is it not available
on purpose?

>2)  /latest is also removed from variable. Would it make a difference?

No.  It's just part of a variable's name (the slash has no special meaning
either).
Naga Malleswari April 12, 2020, 9:09 p.m. UTC | #2
Hi Danny

Is there a suggestion how to work on this.


Meanwhile i submitted another patch, please review

http://debbugs.gnu.org/cgi/bugreport.cgi?bug=40546


On 10/04/20 3:41 am, Danny Milosavljevic wrote:
> Hi,
>
> On Fri, 10 Apr 2020 02:12:42 +0530
> Naga Malleswari <nagamalli@riseup.net> wrote:
>
>> On 09/04/20 3:49 am, Danny Milosavljevic wrote:
>>> + (inherit libxfce4ui-1)
>>> +    (name "libxfce4ui") ; not necessary but I like it for no reason
>>> +    (version "4.15.2")
>>> +    (source (origin ; necessary block!!  
>> I used the same. I added name block. It worked !!!
>> 1) If name block is removed in the latest [libxfce4ui package], it's building the
>> older version. Why??
> If I remove (name "libxfce4ui") from the latest libxfce4ui package, and then
> invoke
>
>   make -j5 SUBDIRS=
>
> then I get an error
>
>   error: name: unbound variable.
>
> from the compilation of gnu/packages/xfce.scm.
> So that's why the latest libxfce4ui package would never be loaded into guix
> (it's broken) and instead the other one would be used.
>
> I'm not sure why that is the case.  It's certainly different to most other
> programming languages.  @Ludo?
>
> @Ludo: Reduced test case:
>
>   ,use (guix packages)
>   (define-public a
>     (package
>       (name "a")
>       (version name)
>       (source #f) (build-system #f) (synopsis #f) (description #f) (license #f) (home-page #f)))
>
>   (define-public b
>     (package
>       (inherit a)
>       (version name))) ; error message here
>
> Error message:
>
>   ;;; <stdin>:9:4: warning: possibly unbound variable `name'
>   <unnamed port>:9:4: In procedure module-lookup: Unbound variable: name
>
> What's happening here?  I would have expected NAME to be available from the
> descendant record and accessing the ancestor record... is it not available
> on purpose?
>
>> 2)  /latest is also removed from variable. Would it make a difference?
> No.  It's just part of a variable's name (the slash has no special meaning
> either).
Danny Milosavljevic April 13, 2020, 7:27 p.m. UTC | #3
Hi Naga,

when trying to build the dependents, I get a build failure in
xfce4-equake-plugin.

Please fix xfce4-equake-plugin to also use libxfce4ui-1.
Same for xfce4-kbdleds-plugin.
Same for xfce4-mailwatch-plugin.

Otherwise OK.
ashish.is--- via Guix-patches" via April 14, 2020, 5:07 p.m. UTC | #4
Naga, Danny,

What's the reason for adding an unstable version?  We don't 
usually do that in Guix.

Is this required for some other package?

Sorry for not bringing this up sooner; I'm still slogging through 
the backlog in a most random way.

Kind regards,

T G-R
Danny Milosavljevic April 19, 2020, 3:59 p.m. UTC | #5
Hi T G-R,
Hi Naga,

whoops, I've forgotten that that would be an unstable version.

Thanks for telling us.

Let's not merge this update then.

I've already merged the update of libxfce4util to 4.15.0--should we revert that?

Naga, please if possible let's only add stable releases to Guix.
If they are experimental, let's not add them to Guix if it can be helped.
diff mbox series

Patch

From ce3d3d40a09631de05fd45eaec964d5473a4ca73 Mon Sep 17 00:00:00 2001
From: Naga Malleswari <nagamalli@riseup.net>
Date: Fri, 10 Apr 2020 01:59:43 +0530
Subject: [PATCH] gnu: libxfce4ui: Add 4.15.2.

* gnu/packages/xfce.scm (libxfce4ui): New variable.
---
 gnu/packages/xfce.scm | 18 ++++++++++++++++--
 1 file changed, 16 insertions(+), 2 deletions(-)

diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index 0628b03207..9556d5aa39 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -163,7 +163,7 @@  Xfce Desktop Environment.")
 storage system.")
     (license lgpl2.0+)))
 
-(define-public libxfce4ui
+(define-public libxfce4ui-1
   (package
     (name "libxfce4ui")
     (version "4.14.1")
@@ -201,6 +201,20 @@  storage system.")
 to share commonly used Xfce widgets among the Xfce applications.")
     (license lgpl2.0+)))
 
+(define-public libxfce4ui
+  (package
+    (inherit libxfce4ui-1)
+    (name "libxfce4ui")
+    (version "4.15.2")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "https://archive.xfce.org/src/xfce/"
+                                  name "/" (version-major+minor version) "/"
+                                  name "-" version ".tar.bz2"))
+              (sha256
+               (base32
+                "0069da27chxrgylbzcm9vhzpfnvkii2n2dz8g6jlwfcr82arkayb"))))))
+
 (define-public exo
   (package
     (name "exo")
@@ -1449,7 +1463,7 @@  performance (bytes transferred per second).")
      `(("intltool" ,intltool)
        ("pkg-config" ,pkg-config)))
     (inputs
-     `(("libxfce4ui" ,libxfce4ui)
+     `(("libxfce4ui" ,libxfce4ui-1)
        ("xfce4-panel" ,xfce4-panel)
        ("gtk+-2" ,gtk+-2)))
     (home-page
-- 
2.25.1