diff mbox series

[bug#68972] gnu: Add tagainijisho.

Message ID 39103f77d7cfb80bad32f53e90d85257d9475314.1707315570.git.~@wolfsden.cz
State New
Headers show
Series [bug#68972] gnu: Add tagainijisho. | expand

Commit Message

Tomas Volf Feb. 7, 2024, 2:19 p.m. UTC
* gnu/packages/education.scm (tagainijisho): New variable.

Change-Id: I85834c9e91a743540ef751e0c2bb3138b4c3b762
---
 gnu/packages/education.scm | 35 +++++++++++++++++++++++++++++++++++
 1 file changed, 35 insertions(+)


base-commit: cce7a6d2d2b18f51d1fcab67b02a38c11d6f4f2d

Comments

Nicolas Goaziou Feb. 22, 2024, 9:28 p.m. UTC | #1
Hello,

Tomas Volf <~@wolfsden.cz> writes:

> * gnu/packages/education.scm (tagainijisho): New variable.

Thank you.

I tweaked the description and applied the patch.

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/education.scm b/gnu/packages/education.scm
index 7b72ed0349..c70f263335 100644
--- a/gnu/packages/education.scm
+++ b/gnu/packages/education.scm
@@ -1161,3 +1161,38 @@  (define-public mazo
     (description "Mazo is a learning application that helps you memorize
 simple concepts using multimedia flash cards and spaced reviews.")
     (license license:public-domain)))
+
+(define-public tagainijisho
+  (package
+    (name "tagainijisho")
+    (version "1.2.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://github.com/Gnurou/tagainijisho/releases/download/"
+             version
+             "/tagainijisho-"
+             version
+             ".tar.gz"))
+       (sha256
+        (base32
+         "00whfcnpn42asxmafcfbcmpwfwyv40qaqdk28psa1vp0lainmyhh"))))
+    (build-system qt-build-system)
+    (arguments
+     '(#:tests? #f)) ; no test target
+    (native-inputs
+     (list qttools-5))
+    (synopsis "Japanese dictionary and learning assistant")
+    (description "Tagaini Jisho is a free, open-source Japanese dictionary and
+kanji lookup tool for Windows, MacOS X and Linux and aims at becoming your
+Japanese study assistant.  It allows you to quickly search for entries and
+mark those that you wish to study, along with tags and personal notes.  It
+also let you train entries you are studying and follows your progression in
+remembering them.  Finally, it makes it easy to review entries you did not
+remember by listing them on screen or printing them on a small booklet.
+
+Tagaini Jisho also features complete stroke order animations for more than
+6000 kanji.")
+    (home-page "https://www.tagaini.net")
+    (license license:gpl3+)))