diff mbox series

[bug#62439] gnu: nim: Update to 1.6.12.

Message ID 388d0ef1f46b45c91c8804096f2a2f35f3539742.1679747022.git.greytest@disroot.org
State New
Headers show
Series [bug#62439] gnu: nim: Update to 1.6.12. | expand

Commit Message

Gruruya March 25, 2023, 12:30 p.m. UTC
Without the attached patch, Nim is broken on Guix as it searches
for its stdlib in /lib while it was placed in /lib/nim.

* gnu/packages/nim: Update to 1.6.12.
[patch-installer]: Install stdlib source to the right directory.
[patch-more-shebangs]: Edit substitute* to point to the new osproc source.
---
 gnu/packages/nim.scm | 8 +++++---
 1 file changed, 5 insertions(+), 3 deletions(-)


base-commit: a7f118d062db4408b23505750c44a1f996496c43

Comments

Efraim Flashner June 6, 2023, 5:51 p.m. UTC | #1
Patch pushed! Thanks.
diff mbox series

Patch

diff --git a/gnu/packages/nim.scm b/gnu/packages/nim.scm
index 6da382119f..ebcff26c7b 100644
--- a/gnu/packages/nim.scm
+++ b/gnu/packages/nim.scm
@@ -5,6 +5,7 @@ 
 ;;; Copyright © 2020 Tanguy Le Carrour <tanguy@bioneland.org>
 ;;; Copyright © 2022 (unmatched parenthesis <paren@disroot.org>
 ;;; Copyright © 2022 Trevor Richards <trev@trevdev.ca>
+;;; Copyright © 2023 Gruruya <greytest@disroot.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -36,14 +37,14 @@  (define-module (gnu packages nim)
 (define-public nim
   (package
     (name "nim")
-    (version "1.6.6")
+    (version "1.6.12")
     (source
      (origin
       (method url-fetch)
       (uri (string-append "https://nim-lang.org/download/"
                           name "-" version ".tar.xz"))
       (sha256
-       (base32 "0lm4450ig8k4l3rzxv6kcqji5l1lzicsw76ckwxm0q9qdz713cb7"))))
+       (base32 "1hjd9dxhqzn2ifr988li8q7v6kxpxlcqbdllfd6lsq3knw50pvxc"))))
     (build-system gnu-build-system)
     (arguments
      `(#:tests? #f          ; TODO: Investigate tests failures.
@@ -55,6 +56,7 @@  (define-public nim
                (let ((out (assoc-ref outputs "out")))
                  (substitute* "install.sh"
                   (("/usr/local") out)
+                  (("/lib/nim") "/lib")
                   (("/opt/nimble") (string-append out "/share/nimble"))
                   (("configdir=/etc/nim")
                    (string-append "configdir=" out "/etc/nim"))))))
@@ -102,7 +104,7 @@  (define-public nim
                                 "lib/pure/osproc.nim"
                                 "lib/pure/strscans.nim")
                    (("/bin/sh") sh))
-                 (substitute* (find-files "c_code" "stdlib_osproc\\.nim\\.c")
+                 (substitute* (find-files "c_code" "@m\\.\\.@slib@spure@sosproc\\.nim\\.c")
                    (("\"/bin/sh\", 7") (format #f "~s, ~s" sh (string-length sh)))))))
            (replace 'build
              (lambda* (#:key (parallel-build? #t) #:allow-other-keys)