diff mbox series

[bug#40398] gnu: Add jsonrpc-glib.

Message ID 3867326c930f269acf52e72bc93e49f2af53fbcc.camel@zrythm.org
State Accepted
Headers show
Series [bug#40398] gnu: Add jsonrpc-glib. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Alexandros Theodotou April 2, 2020, 11:47 p.m. UTC
Hi,

I tried building gnome-builder but I was having unknown problems so I
gave up. Anyway, this is one of its dependencies so it would make the
life of whoever tries to package gnome builder later easier.

Thanks,
Alex

Comments

Efraim Flashner April 19, 2020, 6:44 p.m. UTC | #1
It looks like this patch was applied, closing the bug
diff mbox series

Patch

From 4d96ac7b836f1c1029d79c1fa632d4cc16cb7e9c Mon Sep 17 00:00:00 2001
From: Alexandros Theodotou <alex@zrythm.org>
Date: Fri, 3 Apr 2020 00:44:07 +0100
Subject: [PATCH] gnu: Add jsonrpc-glib.

* gnu/packages/gnome.scm: (jsonrpc-glib) New variable.
---
 gnu/packages/gnome.scm | 30 ++++++++++++++++++++++++++++++
 1 file changed, 30 insertions(+)

diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index b29acf3225..8d461330de 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -9942,3 +9942,33 @@  to.")
 environment.  Its main purpose is the manual transcription of spoken
 audio files.")
       (license license:gpl3+))))
+
+(define-public jsonrpc-glib
+  (package
+    (name "jsonrpc-glib")
+    (version "3.32.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                     (url "https://gitlab.gnome.org/GNOME/jsonrpc-glib.git")
+                     (commit version)))
+              (file-name (string-append name "-" version "-checkout"))
+              (sha256
+                (base32
+                  "0mjr4g6jm3nwsjw0mnwnxr7ndnzaq2b2pr92xk1dmnca5znmal34"))))
+    (build-system meson-build-system)
+    (inputs
+     `(("glib" ,glib)
+       ("gobject-introspection" ,gobject-introspection)
+       ("json-glib" ,json-glib)
+       ("vala" ,vala)))
+    (native-inputs
+     `(("pkg-config" ,pkg-config)))
+    (home-page "https://gitlab.gnome.org/GNOME/jsonrpc-glib")
+    (synopsis "JSON-RPC library for GLib")
+    (description "Jsonrpc-GLib is a library to communicate with JSON-RPC
+based peers in either a synchronous or asynchronous fashion.  It also
+allows communicating using the GVariant serialization format instead of
+JSON when both peers support it.  You might want that when communicating
+on a single host to avoid parser overhead and memory-allocator fragmentation.")
+    (license license:lgpl2.1+)))
-- 
2.26.0