[bug#77393] gnu: deluge: Backport fix for deluge-console.
Commit Message
Without this fix, the command is not usable from scripting, since it always
fails to report the result with:
<Deferred at 0x7f29b3879780 current result: None>
Upstream already has a fix, and it will be present in 2.1.2, so let us
backport it for now.
* gnu/packages/bittorrent.scm (deluge)[arguments]<#:phases>: Add
'fix-deluge-console.
Change-Id: Ifdbcb541aeefbc727890cec2356d346c7fa1dd5d
---
I am not sure whether we usually backport fixes, but I needed this to get
deluge-console working for me, so I might as well send it. Feel free to close
if it goes against some policy.
gnu/packages/bittorrent.scm | 7 +++++++
1 file changed, 7 insertions(+)
--
2.48.1
Comments
Backporting fixes is perfectly fine! I have added a small comment that
it should be removed after the next release to make an update easier,
and pushed.
Thanks,
Andreas
@@ -20,6 +20,7 @@
;;; Copyright © 2023 Clément Lassieur <clement@lassieur.org>
;;; Copyright © 2024 Noisytoot <ron@noisytoot.org>
;;; Copyright © 2024 Zheng Junjie <873216071@qq.com>
+;;; Copyright © 2025 Tomas Volf <~@wolfsden.cz>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -628,6 +629,12 @@ (define-public deluge
`(#:tests? #f
#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'fix-deluge-console
+ (lambda _
+ ;; Backport patch for: https://dev.deluge-torrent.org/ticket/3582
+ (substitute* "deluge/ui/console/__init__.py"
+ ((" return Console\\(\\).start\\(\\)")
+ " Console().start()"))))
(add-after 'install 'wrap
(lambda* (#:key native-inputs inputs outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out"))