diff mbox series

[bug#41293,1/5] gnu: Add pantheon-stylesheet.

Message ID 3824f977c165be2d8e870ba4a9702625e9821e8a.1696162981.git.altadil@protonmail.com
State New
Headers show
Series [bug#41293,1/5] gnu: Add pantheon-stylesheet. | expand

Commit Message

altadil Oct. 1, 2023, 12:41 p.m. UTC
* gnu/packages/pantheon.scm (pantheon-stylesheet): New variable.
---
This package is not very useful by itself, but hopefully will be, once
we manage to get more of Pantheon into Guix. :)
guix build --rounds=2 was successfully run on a Zen4 CPU,
for the following --system= options:
- x86_64-linux
- i686-linux
- aarch64-linux
- armhf-linux
- riscv64-linux.
I am still a packaging noob, so apologies in advance for my mistakes
in this patch series, and thanks for the help!
 gnu/packages/pantheon.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)


base-commit: 337dbf6867597b6e3b72b0bdb2152a42a9f41dbc
diff mbox series

Patch

diff --git a/gnu/packages/pantheon.scm b/gnu/packages/pantheon.scm
index 5b83b96801..55cb65045e 100644
--- a/gnu/packages/pantheon.scm
+++ b/gnu/packages/pantheon.scm
@@ -132,6 +132,28 @@  (define-public pantheon-calculator
 desktop.")
     (license license:gpl3)))
 
+(define-public pantheon-stylesheet
+  (package
+    (name "pantheon-stylesheet")
+    (version "7.2.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/elementary/stylesheet")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0l1xv05zl0jfs9kfv3rnz821a442rpywcvxbcnsm6gp4q0kha7b5"))))
+    (build-system meson-build-system)
+    (native-inputs (list gettext-minimal)) ;for msgfmt
+    (inputs (list sassc))
+    (synopsis "GTK stylesheet for the Pantheon desktop")
+    (description "pantheon-stylesheet is the GTK Stylesheet for the Pantheon
+desktop environment (originally from elementary OS).")
+    (home-page "https://elementary.io/open-source")
+    (license license:gpl3+)))
+
 (define-public pantheon-terminal
   (package
     (name "pantheon-terminal")