diff mbox series

[bug#38120] gnu: Add geonkick.

Message ID 380d1999ff43dd25ce4772899303cf5e@posteo.net
State Accepted
Headers show
Series [bug#38120] gnu: Add geonkick. | expand

Commit Message

Alexandros Theodotou Nov. 8, 2019, 10:13 a.m. UTC
From 09c3a68bfd70d80984a5956fad0596bb7c3e07ac Mon Sep 17 00:00:00 2001
 From: Alexandros Theodotou <alex@zrythm.org>
Date: Fri, 8 Nov 2019 10:11:50 +0000
Subject: [PATCH] gnu: Add geonkick.

* gnu/packages/music.scm: (geonkick): New variable.
---
  gnu/packages/music.scm | 40 ++++++++++++++++++++++++++++++++++++++++
  1 file changed, 40 insertions(+)

+percussion such as kicks, snares, hit-hats, shakers, claps and sticks. 
It can
+also play and mix samples.")
+    (home-page "https://gitlab.com/iurie/geonkick")
+    (license license:gpl3+)))

Comments

Marius Bakke Nov. 10, 2019, 10:17 p.m. UTC | #1
Alexandros Theodotou <alex@zrythm.org> writes:

>  From 09c3a68bfd70d80984a5956fad0596bb7c3e07ac Mon Sep 17 00:00:00 2001
>  From: Alexandros Theodotou <alex@zrythm.org>
> Date: Fri, 8 Nov 2019 10:11:50 +0000
> Subject: [PATCH] gnu: Add geonkick.
>
> * gnu/packages/music.scm: (geonkick): New variable.

[...]

> +       ("jack", jack-1) ; for the standalone

Standalone what?  :-)

Otherwise LGTM modulo indentation issues.
diff mbox series

Patch

diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index a30765e87f..eae05499a1 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -24,6 +24,7 @@ 
  ;;; Copyright © 2019 Jakob L. Kreuze <zerodaysfordays@sdf.lonestar.org>
  ;;; Copyright © 2019 raingloom <raingloom@protonmail.com>
  ;;; Copyright © 2019 David Wilson <david@daviwil.com>
+;;; Copyright © 2019 Alexandros Theodotou <alex@zrythm.org>
  ;;;
  ;;; This file is part of GNU Guix.
  ;;;
@@ -4699,3 +4700,42 @@  You can also get metadata about the playing track 
such as the artist and title
  for integration into status line generators or other command-line 
tools.")
      (home-page "https://github.com/altdesktop/playerctl")
      (license license:lgpl3+)))
+
+(define-public geonkick
+  (package
+    (name "geonkick")
+    (version "1.9.0")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (string-append 
"https://gitlab.com/iurie/geonkick/-/archive/v"
+                            version "/geonkick-v" version ".tar.gz"))
+        (sha256
+          (base32
+            "0wp8w5q69c1nrcc4qkcg0slakkpzp9ngw25iih8zhcl4hrjv42fd"))))
+    (build-system cmake-build-system)
+    (arguments
+     `(#:tests? #f ; no tests included
+       #:configure-flags
+       (list (string-append "-DGKICK_REDKITE_SDK_PATH="
+                            (assoc-ref %build-inputs "redkite"))
+             (string-append "-DCMAKE_INSTALL_PREFIX="
+                            (assoc-ref %outputs "out")))))
+    (inputs
+     `(("cairo" ,cairo)
+       ("hicolor-icon-theme" ,hicolor-icon-theme)
+       ("jack", jack-1) ; for the standalone
+       ("libsndfile", libsndfile)
+       ("libx11", libx11)))
+    (native-inputs
+     `(("lv2", lv2)
+       ("pkg-config", pkg-config)
+       ("sord", sord)
+       ("rapidjson", rapidjson)
+       ("redkite", redkite)))
+    (synopsis "Percussion synthesizer")
+    (description "Geonkick is a synthesizer that can synthesize 
elements of