diff mbox series

[bug#62199,v6] gnu: Add emacs-fdroid.

Message ID 380be5e1db0609350e16901c0f83a2ad95179235.1707683865.git.mail@migalmoreno.com
State New
Headers show
Series [bug#62199,v6] gnu: Add emacs-fdroid. | expand

Commit Message

Miguel Ángel Moreno Feb. 11, 2024, 8:38 p.m. UTC
* gnu/packages/android.scm (emacs-fdroid): New variable.

Change-Id: I68358b5490406aa6ee24391bee6e69bebc574d96
---
 gnu/packages/android.scm | 31 +++++++++++++++++++++++++++++++
 1 file changed, 31 insertions(+)


base-commit: 6f78803b01d416ab421ba860751b764b9e4f33db
-- 
2.41.0



-- 
Best regards,
Miguel Ángel Moreno

Comments

Ludovic Courtès Feb. 18, 2024, 2:57 p.m. UTC | #1
Hi,

Miguel Ángel Moreno <mail@migalmoreno.com> skribis:

> * gnu/packages/android.scm (emacs-fdroid): New variable.
>
> Change-Id: I68358b5490406aa6ee24391bee6e69bebc574d96

Applied, thanks!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/android.scm b/gnu/packages/android.scm
index 32c295f9e4..a03df8f24e 100644
--- a/gnu/packages/android.scm
+++ b/gnu/packages/android.scm
@@ -36,6 +36,7 @@  (define-module (gnu packages android)
   #:use-module (guix git-download)
   #:use-module (guix build-system android-ndk)
   #:use-module (guix build-system cmake)
+  #:use-module (guix build-system emacs)
   #:use-module (guix build-system gnu)
   #:use-module (guix build-system go)
   #:use-module (guix build-system python)
@@ -1224,6 +1225,36 @@  (define-public fdroidcl
     (home-page "https://github.com/mvdan/fdroidcl")
     (license license:bsd-3)))
 
+(define-public emacs-fdroid
+  (package
+    (name "emacs-fdroid")
+    (version "0.1.1")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/migalmoreno/fdroid.el")
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1gv4kfir12bbi17cm5hpx197m8dbw1xwqp0z6qb3vc0fdnyis35j"))))
+    (build-system emacs-build-system)
+    (arguments
+     (list
+      #:phases #~(modify-phases %standard-phases
+                   (add-after 'unpack 'patch-file-name
+                     (lambda* (#:key inputs #:allow-other-keys)
+                       (emacs-substitute-variables "fdroid.el"
+                         ("fdroid-program"
+                          (search-input-file inputs "/bin/fdroidcl"))))))))
+    (inputs (list fdroidcl))
+    (home-page "https://github.com/migalmoreno/fdroid.el")
+    (synopsis "Manage F-Droid packages from Emacs")
+    (description "This package is an Emacs interface to F-Droid.  Its purpose
+is to aid in the management of F-Droid packages for an Android device or an
+emulator inside the comfort of Emacs.")
+    (license license:gpl3+)))
+
 (define-public enjarify
   (package
     (name "enjarify")