diff mbox series

[bug#40063,2/2] gnu: bitlbee-discord: update to working version

Message ID 38089017.3258274.1584214496561@mail.yahoo.com
State Accepted
Headers show
Series [bug#40063,1/2] gnu: bitlbee-discord: Fix build failure | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Deslauriers, Douglas via Guix-patches" via March 14, 2020, 7:34 p.m. UTC
The latest stable version of bitlbee-discord is partially incompatible with discord as it exists now, so i upgraded to the latest git version which functions correctly.

Comments

Leo Famulari March 15, 2020, 5:32 p.m. UTC | #1
On Sat, Mar 14, 2020 at 07:34:56PM +0000, Adrian Fullmer via Guix-patches via wrote:
> The latest stable version of bitlbee-discord is partially incompatible with discord as it exists now, so i upgraded to the latest git version which functions correctly.

Is there a link to any upstream bug reports about this?
Christopher Baines Nov. 20, 2020, 9:37 p.m. UTC | #2
Leo Famulari <leo@famulari.name> writes:

> On Sat, Mar 14, 2020 at 07:34:56PM +0000, Adrian Fullmer via Guix-patches via wrote:
>> The latest stable version of bitlbee-discord is partially
>> incompatible with discord as it exists now, so i upgraded to the
>> latest git version which functions correctly.
>
> Is there a link to any upstream bug reports about this?

Not sure you got this previous email Adrian, but is this Bitlbee fix
something you're still interested in getting merged?

Thanks,

Chris
Maxim Cournoyer July 14, 2021, 1:05 p.m. UTC | #3
Hello,

Christopher Baines <mail@cbaines.net> writes:

> Leo Famulari <leo@famulari.name> writes:
>
>> On Sat, Mar 14, 2020 at 07:34:56PM +0000, Adrian Fullmer via Guix-patches via wrote:
>>> The latest stable version of bitlbee-discord is partially
>>> incompatible with discord as it exists now, so i upgraded to the
>>> latest git version which functions correctly.
>>
>> Is there a link to any upstream bug reports about this?
>
> Not sure you got this previous email Adrian, but is this Bitlbee fix
> something you're still interested in getting merged?

I've merged the fix to the build failure as
a6a4d4b843e8fcf35009ca556d9ed25a700b52d5, and updated the package to
0.4.3 in e69e0c43f867f23127029fd6959534f6a130bcfe.  Let me know if
something still needs to be done!

Closing.

Maxim
diff mbox series

Patch

From f53eb6bc1f9659430617a3232239411e1792549d Mon Sep 17 00:00:00 2001
From: Adrian Fullmer <adrianfullmer@yahoo.com>
Date: Sat, 14 Mar 2020 12:42:06 -0500
Subject: [PATCH 2/2] gnu: bitlbee-discord: update to working version

---
 gnu/packages/messaging.scm | 78 +++++++++++++++++++-------------------
 1 file changed, 40 insertions(+), 38 deletions(-)

diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 72c505c6d9..75cf5375c6 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -223,50 +223,52 @@  identi.ca and status.net).")
     (license (list license:gpl2+ license:bsd-2))))
 
 (define-public bitlbee-discord
-  (package
-    (name "bitlbee-discord")
-    (version "0.4.2")
-    (source
-     (origin
+  (let ((commit "3061edd283b4e886384e5e8cad10f92dc45f3ee7")
+        (revision "0"))
+    (package
+     (name "bitlbee-discord")
+     (version (git-version "0.4.2" revision commit))
+     (source
+      (origin
        (method git-fetch)
        (uri (git-reference
              (url "https://github.com/sm00th/bitlbee-discord.git")
-             (commit version)))
+             (commit commit)))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "02pigk2vbz0jdz11f96sygdvp1j762yjn62h124fkcsc070g7a2f"))))
-    (build-system gnu-build-system)
-    (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         (add-after 'unpack 'patch-autogen
-           (lambda _
-             (let ((sh (which "sh")))
-               (substitute* "autogen.sh" (("/bin/sh") sh))
-               (setenv "CONFIG_SHELL" sh))
-             #t))
-         (replace 'configure
-           (lambda* (#:key inputs outputs #:allow-other-keys)
-             (invoke "./configure"
-                     (string-append "--with-bdatadir="
-                                    (assoc-ref outputs "out")
-                                    "/share/bitlbee/")
-                     (string-append "--with-plugindir="
-                                    (assoc-ref outputs "out")
-                                    "/lib/bitlbee/")))))))
-    (inputs `(("glib" ,glib)))
-    (native-inputs `(("pkg-config" ,pkg-config)
-                     ("autoconf" ,autoconf)
-                     ("automake" ,automake)
-                     ("texinfo" ,texinfo)
-                     ("libtool" ,libtool)
-                     ("bitlbee" ,bitlbee) ; needs bitlbee headers
-                     ("bash" ,bash)))
-    (synopsis "Discord plugin for Bitlbee")
-    (description "Bitlbee-discord is a plugin for Bitlbee witch provides
+        (base32 "1d6nkr7wfrhra09ql258hvhr6q8kmnigcr14hjbwk10kqcb277y6"))))
+     (build-system gnu-build-system)
+     (arguments
+      `(#:phases
+        (modify-phases %standard-phases
+                       (add-after 'unpack 'patch-autogen
+                                  (lambda _
+                                    (let ((sh (which "sh")))
+                                      (substitute* "autogen.sh" (("/bin/sh") sh))
+                                      (setenv "CONFIG_SHELL" sh))
+                                    #t))
+                       (replace 'configure
+                                (lambda* (#:key inputs outputs #:allow-other-keys)
+                                         (invoke "./configure"
+                                                 (string-append "--with-bdatadir="
+                                                                (assoc-ref outputs "out")
+                                                                "/share/bitlbee/")
+                                                 (string-append "--with-plugindir="
+                                                                (assoc-ref outputs "out")
+                                                                "/lib/bitlbee/")))))))
+     (inputs `(("glib" ,glib)))
+     (native-inputs `(("pkg-config" ,pkg-config)
+                      ("autoconf" ,autoconf)
+                      ("automake" ,automake)
+                      ("texinfo" ,texinfo)
+                      ("libtool" ,libtool)
+                      ("bitlbee" ,bitlbee) ; needs bitlbee headers
+                      ("bash" ,bash)))
+     (synopsis "Discord plugin for Bitlbee")
+     (description "Bitlbee-discord is a plugin for Bitlbee witch provides
 access to servers running the Discord protocol.")
-    (home-page "https://github.com/sm00th/bitlbee-discord/")
-    (license license:gpl2+)))
+     (home-page "https://github.com/sm00th/bitlbee-discord/")
+     (license license:gpl2+))))
 
 (define-public hexchat
   (package
-- 
2.25.1