[bug#77161] gnu: Add openrdap.

Message ID 37JRLRMBSTPSU.3T33BQ6Q7K2MI@example.com
State New
Headers
Series [bug#77161] gnu: Add openrdap. |

Commit Message

B. Wilson March 22, 2025, 5:11 a.m. UTC
  
  

Comments

Thomas Ieong March 23, 2025, 10:34 a.m. UTC | #1
user guix
usertag 77161 + reviewed-looks-good
thanks

Guix QA review form submission:

No checks recorded.
  
Thomas Ieong March 23, 2025, 10:38 a.m. UTC | #2
user guix
usertag 77161 + reviewed-looks-good
thanks

Guix QA review form submission:

No checks recorded.
  
Andreas Enge March 31, 2025, 10:34 a.m. UTC | #3
Thanks for the patch and the review!
I have checked the license and pushed.

Andreas
  

Patch

From 4d32190aef31f0b3e08b91251949b57e957959f2 Mon Sep 17 00:00:00 2001
From: "B. Wilson" <elaexuotee@wilsonb.com>
Date: Sat, 22 Mar 2025 13:47:57 +0900
Subject: [PATCH] gnu: Add openrdap.

* gnu/packages/networking.scm (openrdap): New variables.
---
 gnu/packages/networking.scm | 32 ++++++++++++++++++++++++++++++++
 1 file changed, 32 insertions(+)

diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 65d44e975a..995db24efb 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -66,6 +66,7 @@ 
 ;;; Copyright © 2024 Alexey Abramov <levenson@mmer.org>
 ;;; Copyright © 2024 James Smith <jsubuntuxp@disroot.org>
 ;;; Copyright © 2025 Sughosha <sughosha@disroot.org>
+;;; Copyright © 2025 B. Wilson <elaexuotee@wilsonb.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -5125,3 +5126,34 @@  (define-public dropwatch
 recording packets that are dropped by the kernel.  It provides the commands
 @command{dropwatch} and @command{dwdump}.")
     (license license:gpl2+)))
+
+(define-public openrdap
+  (package
+    (name "openrdap")
+    (version "0.9.1")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/openrdap/rdap")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1w3kwxh3hvkp5x1m6i4ijydmpfpibgf9jkviqrvpcadh335989hn"))))
+    (build-system go-build-system)
+    (arguments
+     (list
+      #:unpack-path "github.com/openrdap/rdap"
+      #:import-path "github.com/openrdap/rdap/cmd/rdap"))
+    (propagated-inputs (list go-golang-org-x-crypto
+                             go-github-com-mitchellh-go-homedir
+                             go-github-com-jarcoal-httpmock
+                             go-github-com-davecgh-go-spew
+                             go-github-com-alecthomas-kingpin-v2))
+    (home-page "https://www.openrdap.org/")
+    (synopsis "Command line RDAP client")
+    (description
+     "OpenRDAP is a command line client for the Registration Data Access
+Protocol.  RDAP is modern a replacement for WHOIS, which provides domain name
+and IP address registration information in JSON format over HTTP.")
+    (license license:expat)))
-- 
2.49.0