diff mbox series

[bug#61454,3/5] gnu: linux-libre 5.10: Expose upstream sources.

Message ID 376df4f7d7e926b2bc933ab3600a42e18210bb51.1676213809.git.jlicht@fsfe.org
State New
Headers show
Series Expose upstream linux sources | expand

Commit Message

Jelle Licht Feb. 12, 2023, 3:42 p.m. UTC
From: Jelle Licht <jlicht@fsfe.org>

* gnu/packages/linux.scm (linux-libre-5.10-pristine-source): Re-use extracted
upstream sources from ...
(linux-5.10-source): ... new variable.
---
 gnu/packages/linux.scm | 9 +++++----
 1 file changed, 5 insertions(+), 4 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index ff59084ed2..0a5411f98a 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -522,12 +522,13 @@  (define deblob-scripts-5.10
    linux-libre-5.10-gnu-revision
    (base32 "0mw7qn77y9c6wrnw4rjvf75cpm1w6n1aqqhf8cnghcb97p2yxxrf")
    (base32 "0fk954nniva8a7s423fnfn2wz9j9jdhscc4pqyvwn0wlxxbjgyap")))
-(define-public linux-libre-5.10-pristine-source
+(define-public linux-5.10-source
   (let ((version linux-libre-5.10-version)
         (hash (base32 "1iprbgwdgnylzw4dc8jgims54x8dkq070c9vs4642rp529wgj1yq")))
-   (make-linux-libre-source version
-                            (%upstream-linux-source version hash)
-                            deblob-scripts-5.10)))
+    (%upstream-linux-source version hash)))
+(define-public linux-libre-5.10-pristine-source
+  (let ((version linux-libre-5.10-version))
+   (make-linux-libre-source version linux-5.10-source deblob-scripts-5.10)))
 
 (define-public linux-libre-5.4-version "5.4.231")
 (define-public linux-libre-5.4-gnu-revision "gnu1")