diff mbox series

[bug#73179,2/2] gnu: lablgtk: Remove variable.

Message ID 3764d618c00972d6c1c7e6914df9170cf32330ee.1726058997.git.dev@jpoiret.xyz
State New
Headers show
Series Remove lablgtk. | expand

Commit Message

Josselin Poiret Sept. 11, 2024, 4:02 p.m. UTC
From: Josselin Poiret <dev@jpoiret.xyz>

* gnu/packages/ocaml.scm (lablgtk): Package is no longer used as a dependency.

Change-Id: I7e3d1e5c0bd65a4938b0e08012094603d9d55cc5
---
 gnu/packages/ocaml.scm | 66 ------------------------------------------
 1 file changed, 66 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 804c51c5b0..9d29105cdb 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -1404,72 +1404,6 @@  (define-public ocaml-bigarray-compat
 @code{Stdlib.Bigarray} in OCaml.")
     (license license:isc)))
 
-(define-public lablgtk
-  (package
-    (name "lablgtk")
-    (version "2.18.11")
-    (source (origin
-              (method git-fetch)
-              (uri (git-reference
-                     (url "https://github.com/garrigue/lablgtk")
-                     (commit version)))
-              (file-name (git-file-name name version))
-              (sha256
-               (base32
-                "179ipx0c6bpxm4gz0syxgqy09dp5p4x9qsdil7s9jlx8ffg1mm0w"))))
-    (build-system gnu-build-system)
-    (native-inputs
-     (list ;; Build failure with make-4.4, so we use make-4.2.
-           ;; See <https://github.com/garrigue/lablgtk/issues/170>.
-           gnu-make-4.2
-           ocaml
-           ocaml-findlib
-           pkg-config))
-    ;; FIXME: Add inputs gtkgl-2.0, libpanelapplet-2.0, gtkspell-2.0,
-    ;; and gtk+-quartz-2.0 once available.
-    (inputs
-     (list gtk+-2
-           gtksourceview-2
-           libgnomecanvas
-           libgnomeui
-           libglade
-           (librsvg-for-system)))
-    (arguments
-     `(#:tests? #f ; no check target
-
-       ;; opt: also install cmxa files
-       #:make-flags (list "all" "opt"
-                          (string-append "FINDLIBDIR="
-                                         (assoc-ref %outputs "out")
-                                         "/lib/ocaml"))
-       ;; Occasionally we would get "Error: Unbound module GtkThread" when
-       ;; compiling 'gtkThInit.ml', with 'make -j'.  So build sequentially.
-       #:parallel-build? #f
-
-       #:phases
-         (modify-phases %standard-phases
-           (add-before 'install 'prepare-install
-             (lambda* (#:key inputs outputs #:allow-other-keys)
-               (let ((out (assoc-ref outputs "out"))
-                     (ocaml (assoc-ref inputs "ocaml")))
-                 ;; Install into the output and not the ocaml directory.
-                 (mkdir-p (string-append out "/lib/ocaml"))
-                 (substitute* "config.make"
-                   ((ocaml) out))
-                 #t))))))
-    (home-page "http://lablgtk.forge.ocamlcore.org/")
-    (synopsis "GTK+ bindings for OCaml")
-    (description
-     "LablGtk is an OCaml interface to GTK+ 1.2 and 2.x.  It provides
-a strongly-typed object-oriented interface that is compatible with the
-dynamic typing of GTK+.  Most widgets and methods are available.  LablGtk
-also provides bindings to
-gdk-pixbuf, the GLArea widget (in combination with LablGL), gnomecanvas,
-gnomeui, gtksourceview, gtkspell,
-libglade (and it an generate OCaml code from .glade files),
-libpanel, librsvg and quartz.")
-    (license license:lgpl2.1)))
-
 (define-public binsec
   (package
     (name "binsec")