[bug#75058,rust-team,5/5] gnu: rust-objc2-symbols-0.2: Order alphabetically.

Message ID 374db4abc1253afa2674b6888d01c49ba2a54019.1735032602.git.herman@rimm.ee
State New
Headers
Series [bug#75058,rust-team,1/5] gnu: rust-block-sys-0.2: Order alphabetically. |

Commit Message

Herman Rimm Dec. 24, 2024, 9:45 a.m. UTC
  * gnu/packages/crates-apple.scm (rust-objc2-symbols-0.2): Order.

Change-Id: I543f3c64f1c11043ed70f93fc9f8dd4e2de8d34d
---
 gnu/packages/crates-apple.scm | 44 +++++++++++++++++------------------
 1 file changed, 22 insertions(+), 22 deletions(-)
  

Patch

diff --git a/gnu/packages/crates-apple.scm b/gnu/packages/crates-apple.scm
index ba67428d26..5e89d4f174 100644
--- a/gnu/packages/crates-apple.scm
+++ b/gnu/packages/crates-apple.scm
@@ -1570,6 +1570,28 @@  (define-public rust-objc2-quartz-core-0.2
 framework.")
     (license license:expat)))
 
+(define-public rust-objc2-symbols-0.2
+  (package
+    (name "rust-objc2-symbols")
+    (version "0.2.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "objc2-symbols" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "1p04hjkxan18g2b7h9n2n8xxsvazapv2h6mfmmdk06zc7pz4ws0a"))))
+    (build-system cargo-build-system)
+    (arguments
+     ;; Must specify the desired runtime using Cargo features on non-Apple platforms
+     `(#:skip-build? #t
+       #:cargo-inputs (("rust-objc2" ,rust-objc2-0.5)
+                       ("rust-objc2-foundation" ,rust-objc2-foundation-0.2))))
+    (home-page "https://github.com/madsmtm/objc2")
+    (synopsis "Bindings to the Symbols framework")
+    (description "This package Provides Bindings to the Symbols framework.")
+    (license license:expat)))
+
 (define-public rust-objc2-ui-kit-0.2
   (package
     (name "rust-objc2-ui-kit")
@@ -1604,28 +1626,6 @@  (define-public rust-objc2-ui-kit-0.2
     (description "This package provides bindings to the UIKit framework.")
     (license license:expat)))
 
-(define-public rust-objc2-symbols-0.2
-  (package
-    (name "rust-objc2-symbols")
-    (version "0.2.2")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (crate-uri "objc2-symbols" version))
-       (file-name (string-append name "-" version ".tar.gz"))
-       (sha256
-        (base32 "1p04hjkxan18g2b7h9n2n8xxsvazapv2h6mfmmdk06zc7pz4ws0a"))))
-    (build-system cargo-build-system)
-    (arguments
-     ;; Must specify the desired runtime using Cargo features on non-Apple platforms
-     `(#:skip-build? #t
-       #:cargo-inputs (("rust-objc2" ,rust-objc2-0.5)
-                       ("rust-objc2-foundation" ,rust-objc2-foundation-0.2))))
-    (home-page "https://github.com/madsmtm/objc2")
-    (synopsis "Bindings to the Symbols framework")
-    (description "This package Provides Bindings to the Symbols framework.")
-    (license license:expat)))
-
 (define-public rust-objc2-uniform-type-identifiers-0.2
   (package
     (name "rust-objc2-uniform-type-identifiers")