diff mbox series

[bug#44369] gnu: v4l-utils: Move graphical tools to a separate output

Message ID 3731311604233325@mail.yandex.ru
State Accepted
Headers show
Series [bug#44369] gnu: v4l-utils: Move graphical tools to a separate output | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Ivan Kozlov Nov. 1, 2020, 12:27 p.m. UTC
v4l-utils is a common dependency. Separate graphical tools to avoid pulling in qtbase unless they are referenced.

* gnu/packages/video.scm (v4l-utils)[outputs]: New 'gui' output.
[arguments]: Add 'split' phase.
---
 gnu/packages/video.scm | 28 +++++++++++++++++++++++++++-
 1 file changed, 27 insertions(+), 1 deletion(-)

Comments

Marius Bakke Nov. 10, 2020, 8:57 p.m. UTC | #1
Ivan Kozlov <kanichos@yandex.ru> writes:

> v4l-utils is a common dependency. Separate graphical tools to avoid pulling in qtbase unless they are referenced.

Thanks a lot for this.  I added a comment in the package definition
about it and committed.  It brings the closure size down from 1090.4 MiB
to a mere 104.8 MiB!

I also added a commit that removes the static libraries, further
reducing the size a tiny bit (and ensures that it can be grafted).
diff mbox series

Patch

diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 34b0fbe294..9ff7d0a45a 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -2987,11 +2987,37 @@  tools, XML authoring components, and an extensible plug-in based API.")
                (base32
                 "1bkqlrizx0j2rd6ybam2x17bjrpwzl4v4szmnzm3cmixis3w3npr"))))
     (build-system gnu-build-system)
+    (outputs '("out" "gui"))
     (arguments
      '(#:configure-flags
        (list (string-append "--with-udevdir="
                             (assoc-ref %outputs "out")
-                            "/lib/udev"))))
+                            "/lib/udev"))
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'install 'split
+           (lambda* (#:key outputs #:allow-other-keys)
+             (let ((out (assoc-ref outputs "out"))
+                   (gui (assoc-ref outputs "gui")))
+               (mkdir-p (string-append gui "/bin"))
+               (mkdir-p (string-append gui "/share/man/man1"))
+               (mkdir-p (string-append gui "/share/applications"))
+               (for-each
+                (lambda (prog)
+                  (for-each
+                   (lambda (file)
+                     (rename-file (string-append out file)
+                                  (string-append gui file)))
+                   (list
+                    (string-append "/bin/" prog)
+                    (string-append "/share/man/man1/" prog ".1")
+                    (string-append "/share/applications/" prog ".desktop"))))
+                '("qv4l2" "qvidcap"))
+               (copy-recursively (string-append out "/share/icons")
+                                 (string-append gui "/share/icons"))
+               (delete-file-recursively (string-append out "/share/icons"))
+               (rmdir (string-append out "/share/applications"))
+               #t))))))
     (native-inputs
      `(("perl" ,perl)
        ("pkg-config" ,pkg-config)))