diff mbox series

[bug#60993] gnu: Add emacs-helm-themes.

Message ID 37225ce23dd697d5f91e0012bfe9d4097691a21d.1674324562.git.csantosb@inventati.org
State New
Headers show
Series [bug#60993] gnu: Add emacs-helm-themes. | expand

Commit Message

Cayetano Santos Jan. 21, 2023, 6:09 p.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-helm-themes): New variable.
---
 gnu/packages/emacs-xyz.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)


base-commit: 900d33527c9286a811f064d4bb8f4a9b18d1db0b

Comments

Nicolas Goaziou Jan. 25, 2023, 6:01 p.m. UTC | #1
Hello,

Cayetano Santos via Guix-patches via <guix-patches@gnu.org> writes:

> * gnu/packages/emacs-xyz.scm (emacs-helm-themes): New variable.

Applied with some small tweaks to description and synopsis.

Thank you.

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index dc85764746..f45fcca3d9 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -30991,6 +30991,32 @@  (define-public emacs-helm-fish-completion
 fish-completion.  It can be used in both Eshell and M-x shell.")
     (license license:gpl3+)))
 
+(define-public emacs-helm-themes
+  (let ((version "0.05")
+        (commit "92ee3ad4edf1d068feb0822a05638db99b50a7c0")
+        (revision "1"))
+    (package
+      (name "emacs-helm-themes")
+      (version (git-version version revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/emacsorphanage/helm-themes")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32
+           "1p62gg8nnb6kmb9mk66230p0ap0zwwzhzdxr3j34z5ls574vr6s7"))))
+      (build-system emacs-build-system)
+      (propagated-inputs (list emacs-helm))
+      (home-page "https://github.com/emacsorphanage/helm-themes")
+      (synopsis "Provides theme selection with helm interface")
+      (description
+       "helm-themes.el provide theme selection with helm interface.  Its
+persistent action can set theme temporary.")
+      (license license:gpl3+))))
+
 (define-public emacs-helm-switch-to-repl
   (package
     (name "emacs-helm-switch-to-repl")