diff mbox series

[bug#66801,v4,07/15] gnu: Add elixir-file-system.

Message ID 371a011eb62c7f5234b2c1b7b84adda5f28f618b.1702060484.git.contact@phfrohring.com
State New
Headers show
Series [bug#66801,v4,01/15] build-system: Add mix-build-system. | expand

Commit Message

Pierre-Henry Fröhring Dec. 8, 2023, 6:35 p.m. UTC
From: Pierre-Henry Fröhring <phfrohring@deeplinks.com>

* gnu/packages/elixir-xyz.scm (elixir-file-system): New variable.

Change-Id: I54e9c9069ddf150bb0c882775b0b2c9d5e59abd6
---
 gnu/packages/elixir-xyz.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/elixir-xyz.scm b/gnu/packages/elixir-xyz.scm
index 66c364fb3..f46e470cd 100644
--- a/gnu/packages/elixir-xyz.scm
+++ b/gnu/packages/elixir-xyz.scm
@@ -91,6 +91,28 @@  (define-public elixir-jason
     (home-page "https://hexdocs.pm/jason/")
     (license license:asl2.0)))
 
+(define-public elixir-file-system
+  (package
+    (name "elixir-file-system")
+    (version "0.2.10")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (hexpm-uri name version))
+       (sha256
+        (base32 "1p0myxmnjjds8bbg69dd6fvhk8q3n7lb78zd4qvmjajnzgdmw6a1"))
+       ;; This directory represents source code not needed on UNIX systems.
+       ;; Since we aim at UNIX systems, it is deleted.
+       (snippet '(delete-file-recursively "priv"))))
+    (build-system mix-build-system)
+    (propagated-inputs (list inotify-tools))
+    (arguments (list #:tests? #f)) ;There is no test/ in the source.
+    (synopsis "File system change watcher")
+    (description "Provides a file system change watcher wrapper based on
+[fs](https://github.com/synrc/fs).")
+    (home-page "https://hexdocs.pm/file_system/")
+    (license license:wtfpl2)))
+
 ;;;
 ;;; Avoid adding new packages to the end of this file. To reduce the chances
 ;;; of a merge conflict, place them above by existing packages with similar