@@ -324,44 +324,38 @@ (define-public python-django-localflavor
(license license:bsd-3)))
(define-public python-django-simple-math-captcha
- (package
- (name "python-django-simple-math-captcha")
- (version "1.0.9")
- (home-page "https://github.com/alsoicode/django-simple-math-captcha")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url home-page)
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0fhy9k8haqa1296v0qpg1b5w7y3pyw9qi9z9laj5ijry1gk35qaw"))))
- (build-system python-build-system)
- (arguments
- '(#:phases (modify-phases %standard-phases
- (add-after 'unpack 'patch-six-imports
- (lambda _
- ;; Django no longer bundles six, adjust the imports
- ;; accordingly. The six dependency can likely be
- ;; removed in the next version.
- (substitute* (find-files "." "\\.py$")
- (("from django\\.utils import six")
- "import six"))
- #t))
- (replace 'check
- (lambda _
- (invoke "python" "runtests.py"))))))
- (native-inputs
- (list python-mock))
- (propagated-inputs
- (list python-django python-six))
- (synopsis "Easy-to-use math field/widget captcha for Django forms")
- (description
- "A multi-value-field that presents a human answerable question,
+ (let ((commit "61adb4f43bfc654da61fa7b84ea4f455e31f0bd2")
+ (revision "0"))
+ (package
+ (name "python-django-simple-math-captcha")
+ (version (git-version "1.0.9" revision commit))
+ (home-page "https://github.com/alsoicode/django-simple-math-captcha")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "02fim6xk4islil02xg7j5nqfpmgwzyqni1y17a082fz35d94jd3i"))))
+ (build-system pyproject-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda _
+ (invoke "python" "runtests.py"))))))
+ (native-inputs
+ (list python-mock))
+ (propagated-inputs
+ (list python-django))
+ (synopsis "Easy-to-use math field/widget captcha for Django forms")
+ (description
+ "A multi-value-field that presents a human answerable question,
with no settings.py configuration necessary, but instead can be configured
with arguments to the field constructor.")
- (license license:asl2.0)))
+ (license license:asl2.0))))
(define-public python-django-classy-tags
(package