diff mbox series

[bug#66785] gnu: foot: Update to 1.16.2.

Message ID 37102c04d1f3fbd8abeda6d0f4bab5bc6f4f9001.1698459196.git.jaeme@runbox.com
State New
Headers show
Series [bug#66785] gnu: foot: Update to 1.16.2. | expand

Commit Message

Jaeme Sifat Oct. 28, 2023, 2:13 a.m. UTC
* gnu/packages/terminals.scm (foot): Update to 1.16.2.
[arguments]: use gexps.

Signed-off-by: Jaeme Sifat <jaeme@runbox.com>
Change-Id: I0615f6251a918a572369c05b126853f79e9fca4c
---
 gnu/packages/terminals.scm | 38 ++++++++++++++++++++------------------
 1 file changed, 20 insertions(+), 18 deletions(-)


base-commit: ff1146fb4f7254a8f644f89d7af6b4b566528603

Comments

Christopher Baines Nov. 3, 2023, 10:29 a.m. UTC | #1
Jaeme Sifat via Guix-patches via <guix-patches@gnu.org> writes:

> * gnu/packages/terminals.scm (foot): Update to 1.16.2.
> [arguments]: use gexps.
>
> Signed-off-by: Jaeme Sifat <jaeme@runbox.com>
> Change-Id: I0615f6251a918a572369c05b126853f79e9fca4c
> ---
>  gnu/packages/terminals.scm | 38 ++++++++++++++++++++------------------
>  1 file changed, 20 insertions(+), 18 deletions(-)

Thanks for the patch! I've pushed this to master as
809f461ec112395228acd8e84812f5fe80126dad.

Chris
diff mbox series

Patch

diff --git a/gnu/packages/terminals.scm b/gnu/packages/terminals.scm
index c5cecfa6db..3a23328831 100644
--- a/gnu/packages/terminals.scm
+++ b/gnu/packages/terminals.scm
@@ -37,6 +37,7 @@ 
 ;;; Copyright © 2023 Aaron Covrig <aaron.covrig.us@ieee.org>
 ;;; Copyright © 2023 Foundation Devices, Inc. <hello@foundationdevices.com>
 ;;; Copyright © 2023 Zheng Junjie <873216071@qq.com>
+;;; Copyright © 2023 Jaeme Sifat <jaeme@runbox.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -834,33 +835,34 @@  (define-public cool-retro-term
 (define-public foot
   (package
     (name "foot")
-    (version "1.15.3")
+    (version "1.16.2")
     (home-page "https://codeberg.org/dnkl/foot")
-    (source (origin
-              (method git-fetch)
-              (uri (git-reference (url home-page) (commit version)))
-              (file-name (git-file-name name version))
-              (sha256
-               (base32
-                "1a224i2i7qk170kf2rzyxqcv3lnx9f548lwa37jgjr7i339x4zwf"))))
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url home-page)
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "00wac8li1ac8ncmnlqvz3xnr5pi8gj4v3v341n0h2zzaayv9ngw5"))))
     (build-system meson-build-system)
     (arguments
-     `(;; Using a "release" build is recommended both for performance, and
-       ;; also to address a GCC 10 issue when doing PGO builds.
-       #:build-type "release"
-       ;; Enable LTO as recommended by INSTALL.md.
-       #:configure-flags '("-Db_lto=true")))
-    (native-inputs
-     (list ncurses ;for 'tic'
-           pkg-config scdoc wayland-protocols))
+     (list
+      ;; Using a "release" build is recommended both for performance, and
+      ;; also to address a GCC 10 issue when doing PGO builds.
+      #:build-type "release"
+      ;; Enable LTO as recommended by INSTALL.md.
+      #:configure-flags #~'("-Db_lto=true")))
+    (native-inputs (list ncurses ;for 'tic'
+                         pkg-config scdoc wayland-protocols))
     (native-search-paths
      ;; FIXME: This should only be located in 'ncurses'.  Nonetheless it is
      ;; provided for usability reasons.  See <https://bugs.gnu.org/22138>.
      (list (search-path-specification
             (variable "TERMINFO_DIRS")
             (files '("share/terminfo")))))
-    (inputs
-     (list fcft libxkbcommon wayland))
+    (inputs (list fcft libxkbcommon wayland))
     (synopsis "Wayland-native terminal emulator")
     (description
      "@command{foot} is a terminal emulator for systems using the Wayland