diff mbox series

[bug#63370] gnu: Add emacs-framemove.

Message ID 36ef72b8f78a52274eec6e300996ad4f387c2462.1683550987.git.me@fabionatali.com
State New
Headers show
Series [bug#63370] gnu: Add emacs-framemove. | expand

Commit Message

Fabio Natali May 8, 2023, 1:05 p.m. UTC
Hi, this tiny patch is to add FrameMove, an Emacs package that allows to move
focus across windows and frames. IIUC, it can be particularly useful to EXWM
users. The package is currently hosted on EmacsWiki at
https://www.emacswiki.org/emacs/FrameMove. Hope this helps.

* gnu/packages/emacs-xyz.scm (emacs-framemove): New variable.

Signed-off-by: Fabio Natali <me@fabionatali.com>
---
 gnu/packages/emacs-xyz.scm | 20 ++++++++++++++++++++
 1 file changed, 20 insertions(+)


base-commit: 0e09e8ab1554a7dffd60101cb4e631b348e43c9c

Comments

Nicolas Goaziou May 8, 2023, 4:15 p.m. UTC | #1
Hello,

Fabio Natali <me@fabionatali.com> writes:
>
> * gnu/packages/emacs-xyz.scm (emacs-framemove): New variable.

Thank you.

> Signed-off-by: Fabio Natali <me@fabionatali.com>

In Guix, you don't sign your own commits.

> +       (uri "https://www.emacswiki.org/emacs/download/framemove.el")

This is an issue, because the URI is not stable. Please use GitHub
repository instead: <https://github.com/emacsmirror/framemove>.

> +    (description "@code{emacs-framemove} is similar to the
> @code{windmove.el}

Nicpicks: @code{emacs-framemove} -> Framemove and @code{windmove.el} -> Windmove.

Could you send an updated patch?

Regards,
Fabio Natali May 8, 2023, 7:15 p.m. UTC | #2
Hey Nicolas, thanks for getting back to me so quickly. An updated
version of the patch should be arriving in a minute.

On 2023-05-08, 18:15 +0200, Nicolas Goaziou <mail@nicolasgoaziou.fr> wrote:
> In Guix, you don't sign your own commits.

Ooops, sorry. Fixed in the new patch.

>> +       (uri "https://www.emacswiki.org/emacs/download/framemove.el")
>
> This is an issue, because the URI is not stable. Please use GitHub
> repository instead: <https://github.com/emacsmirror/framemove>.

Fixed.

>> +    (description "@code{emacs-framemove} is similar to the
>> @code{windmove.el}
>
> Nicpicks: @code{emacs-framemove} -> Framemove and @code{windmove.el} -> Windmove.

This is also fixed.

Thanks Nicolas, should you spot anything else, I'm very glad to keep
working on it.

Cheers, Fabio.
Fabio Natali May 10, 2023, 8 a.m. UTC | #3
On 2023-05-08, 20:15 +0100, Fabio Natali <me@fabionatali.com> wrote:
> Hey Nicolas, thanks for getting back to me so quickly. An updated
> version of the patch should be arriving in a minute.

(Just to clarify, the patch ended up arriving a bit earlier than my
above comment, it's here: https://issues.guix.gnu.org/63370#2.)
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 050e6377a3..720cefae18 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -128,6 +128,7 @@ 
 ;;; Copyright © 2023 Juliana Sims <juli@incana.org>
 ;;; Copyright © 2023 Evgeny Pisemsky <evgeny@pisemsky.com>
 ;;; Copyright © 2023 Gabriel Wicki <gabriel@erlikon.ch>
+;;; Copyright © 2023 Fabio Natali <me@fabionatali.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -32435,6 +32436,25 @@  (define-public emacs-windower
 @end itemize")
     (license license:gpl3+)))
 
+(define-public emacs-framemove
+  (package
+    (name "emacs-framemove")
+    (version "0.10")
+    (source
+     (origin
+       (method url-fetch)
+       (uri "https://www.emacswiki.org/emacs/download/framemove.el")
+       (sha256
+        (base32
+         "15fhhywr0y2bd10rp60qkdq521l8ag1is4ahjnd84hl2w0qn7gnw"))))
+    (build-system emacs-build-system)
+    (home-page "https://www.emacswiki.org/emacs/framemove.el")
+    (synopsis "Directional frame selection routines")
+    (description "@code{emacs-framemove} is similar to the @code{windmove.el}
+library, but for frames. It provides a simple set of keystrokes to move the
+input/focus between windows.")
+    (license license:gpl3)))
+
 (define-public emacs-flycheck-cpplint
   (package
     (name "emacs-flycheck-cpplint")