diff mbox series

[bug#40172] gnu: add python-gcovr.

Message ID 36ac7ee63343e5aa26ce9cc8f248c80740317ca3.camel@zrythm.org
State Accepted
Headers show
Series [bug#40172] gnu: add python-gcovr. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Alexandros Theodotou March 21, 2020, 7:47 p.m. UTC
Hi,

This patch adds gcovr.

Thanks,
Alex

Comments

Ludovic Courtès March 23, 2020, 9:47 a.m. UTC | #1
Alexandros Theodotou <alex@zrythm.org> skribis:

> From c624e0ec8bb4ebe2bb7af6a2d86aafbf072c4891 Mon Sep 17 00:00:00 2001
> From: Alexandros Theodotou <alex@zrythm.org>
> Date: Sat, 21 Mar 2020 19:45:14 +0000
> Subject: [PATCH] gnu: add python-gcovr.
>
> * gnu/packages/python-xyz.scm (python-gcovr): New variable.

Applied, thanks!
diff mbox series

Patch

From c624e0ec8bb4ebe2bb7af6a2d86aafbf072c4891 Mon Sep 17 00:00:00 2001
From: Alexandros Theodotou <alex@zrythm.org>
Date: Sat, 21 Mar 2020 19:45:14 +0000
Subject: [PATCH] gnu: add python-gcovr.

* gnu/packages/python-xyz.scm (python-gcovr): New variable.
---
 gnu/packages/python-xyz.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index d0da9b36c3..9ede8b4c93 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -70,6 +70,7 @@ 
 ;;; Copyright © 2020 Jakub Kądziołka <kuba@kadziolka.net>
 ;;; Copyright © 2020 sirgazil <sirgazil@zoho.com>
 ;;; Copyright © 2020 Sebastian Schott <sschott@mailbox.org>
+;;; Copyright © 2020 Alexandros Theodotou <alex@zrythm.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -18358,3 +18359,28 @@  sequences.")
 
 (define-public python2-fuzzywuzzy
   (package-with-python2 python-fuzzywuzzy))
+
+(define-public python-gcovr
+  (package
+    (name "python-gcovr")
+    (version "4.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "gcovr" version))
+       (sha256
+        (base32
+          "0gyady7x3v3l9fm1zan0idaggqqcm31y7g5vxk7h05p5h7f39bjs"))))
+    (build-system python-build-system)
+    (propagated-inputs
+     `(("python-lxml" ,python-lxml)
+       ("python-jinja2" ,python-jinja2)))
+    (home-page "https://gcovr.com/")
+    (synopsis
+      "Utility for generating code coverage results")
+    (description
+      "Gcovr provides a utility for managing the use of the GNU gcov
+utility and generating summarized code coverage results.  It is inspired
+by the Python coverage.py package, which provides a similar utility for
+Python.")
+    (license license:bsd-3)))
-- 
2.25.1