diff mbox series

[bug#38118] gnu: Add avldrums-lv2.

Message ID 3657edb78c1a186745eb5206b54d8f4f@posteo.net
State Accepted
Headers show
Series [bug#38118] gnu: Add avldrums-lv2. | expand

Commit Message

Alexandros Theodotou Nov. 8, 2019, 9:38 a.m. UTC
From aae805260db2b830a35459ae219c780e6619cc14 Mon Sep 17 00:00:00 2001
 From: Alexandros Theodotou <alex@zrythm.org>
Date: Fri, 8 Nov 2019 09:35:38 +0000
Subject: [PATCH] gnu: Add avldrums-lv2.

* gnu/packages/music.scm: (avldrums-lv2): New variable.
---
  gnu/packages/music.scm | 43 ++++++++++++++++++++++++++++++++++++++++++
  1 file changed, 43 insertions(+)

dedicated to Glen MacArthur's
+AVLdrums. This plugin provides a convenient way to sequence and mix 
MIDI drums and
+comes as two separate drumkits: Black Pearl and Red Zeppelin.")
+    (license license:gpl2+)))

Comments

Marius Bakke Nov. 10, 2019, 10:27 p.m. UTC | #1
Alexandros Theodotou <alex@zrythm.org> writes:

>  From aae805260db2b830a35459ae219c780e6619cc14 Mon Sep 17 00:00:00 2001
>  From: Alexandros Theodotou <alex@zrythm.org>
> Date: Fri, 8 Nov 2019 09:35:38 +0000
> Subject: [PATCH] gnu: Add avldrums-lv2.
>
> * gnu/packages/music.scm: (avldrums-lv2): New variable.

[...]

> +    (source
> +      (origin
> +        (method git-fetch)
> +        (uri
> +          (git-reference
> +            (url "https://github.com/x42/avldrums.lv2.git")
> +            (commit (string-append "v" version))
> +            (recursive? #t)))   ; for the 'robtk' submodule

Can we package robtk separately?

> +    (home-page "http://x42-plugins.com/x42/x42-avldrums")

HTTPS                 ^

> +    (synopsis "Drum sample player LV2 plugin dedicated to the AVLinux 
> Drumkits")
> +    (description "avldrums.lv2 is a drum sample player LV2 plugin 
> dedicated to Glen MacArthur's
> +AVLdrums. This plugin provides a convenient way to sequence and mix 
> MIDI drums and
> +comes as two separate drumkits: Black Pearl and Red Zeppelin.")

Make sure to run 'guix lint' before resending these patches, to catch
infraction issues :-)
diff mbox series

Patch

diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index a30765e87f..38d30c5438 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -24,6 +24,7 @@ 
  ;;; Copyright © 2019 Jakob L. Kreuze <zerodaysfordays@sdf.lonestar.org>
  ;;; Copyright © 2019 raingloom <raingloom@protonmail.com>
  ;;; Copyright © 2019 David Wilson <david@daviwil.com>
+;;; Copyright © 2019 Alexandros Theodotou <alex@zrythm.org>
  ;;;
  ;;; This file is part of GNU Guix.
  ;;;
@@ -4699,3 +4700,45 @@  You can also get metadata about the playing track 
such as the artist and title
  for integration into status line generators or other command-line 
tools.")
      (home-page "https://github.com/altdesktop/playerctl")
      (license license:lgpl3+)))
+
+(define-public avldrums-lv2
+  (package
+    (name "avldrums-lv2")
+    (version "0.4.0")
+    (source
+      (origin
+        (method git-fetch)
+        (uri
+          (git-reference
+            (url "https://github.com/x42/avldrums.lv2.git")
+            (commit (string-append "v" version))
+            (recursive? #t)))   ; for the 'robtk' submodule
+        (file-name (string-append name "-v" version))
+        (sha256
+          (base32
+            "1z70rcq6z3gkb4fm8dm9hs31bslwr97zdh2n012fzki9b9rdj5qv"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:tests? #f  ; no "check" target
+       #:make-flags
+       (list (string-append "PREFIX=" (assoc-ref %outputs "out")))
+       #:phases
+       (modify-phases %standard-phases
+         (add-before 'build 'set-CC-variable
+           (lambda _ (setenv "CC" "gcc") #t))
+         (delete 'configure))))
+    (inputs
+     `(("cairo" ,cairo)
+       ("dssi" ,dssi)
+       ("glu" ,glu)
+       ("mesa" ,mesa)
+       ("pango" ,pango)))
+    (native-inputs
+     `(("pkg-config" ,pkg-config)
+       ("lv2" ,lv2)))
+    (home-page "http://x42-plugins.com/x42/x42-avldrums")
+    (synopsis "Drum sample player LV2 plugin dedicated to the AVLinux 
Drumkits")
+    (description "avldrums.lv2 is a drum sample player LV2 plugin