diff mbox series

[bug#48640] Cbc (COIN-OR)

Message ID 36519475-0f45-408e-bb62-c07928f65b44@www.fastmail.com
State Accepted
Headers show
Series [bug#48640] Cbc (COIN-OR) | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Eric Brown May 25, 2021, 6:01 a.m. UTC
Hello All,

Please see the attached patch for Cbc, which is a branch-and-cut solver.

Best regards,
Eric
diff mbox series

Patch

From b48d0a90603b7b2b8263c2e86e45b33cf787974c Mon Sep 17 00:00:00 2001
From: Eric Brown <ecbrown@ericcbrown.com>
Date: Tue, 25 May 2021 00:58:50 -0500
Subject: [PATCH] gnu: Add cbc.

* gnu/packages/maths.scm (cbc): New variable.
---
 gnu/packages/maths.scm | 31 +++++++++++++++++++++++++++++++
 1 file changed, 31 insertions(+)

diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index ee0a69bbd7..63ca2979ae 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -1795,6 +1795,37 @@  large-scale nonlinear optimization.  It provides C++, C, and Fortran
 interfaces.")
     (license license:epl1.0)))
 
+(define-public cbc
+  (package
+    (name "cbc")
+    (version "2.10.5")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "https://www.coin-or.org/download/source/"
+                                  "Cbc/Cbc-" version ".tgz"))
+              (sha256
+               (base32
+                "0wk9vr6zc62gw71v7gnra5wxqlcljcgbhm5lasx236v791b986ns"))
+              (modules '((guix build utils)))
+              (snippet
+               ;; Make sure we don't use the bundled software.
+               '(begin
+                  (delete-file-recursively "ThirdParty")
+                  #t))))
+    (build-system gnu-build-system)
+    (native-inputs
+     `(("gfortran" ,gfortran)
+       ("pkg-config" ,pkg-config)))
+    (inputs
+     `(("openblas" ,openblas)))
+    (home-page "https://www.coin-or.org")
+    (synopsis "Branch-and-Cut solver")
+    (description
+     "Cbc (Coin-or branch and cut) is an open-source mixed integer linear
+programming solver written in C++. It can be used as a callable library or
+using a stand-alone executable.")
+    (license license:epl1.0)))
+
 (define-public clp
   (package
     (name "clp")
-- 
2.31.1