diff mbox series

[bug#73124,v2,3/3] gnu: wlroots: add 0.18

Message ID 364529bb0d4035b63b6f94250aa3637890642a73.1725819647.git.rutherther@protonmail.com
State New
Headers show
Series gnu: wlroots: update on mesa-updates | expand

Commit Message

Rutherther Sept. 8, 2024, 6:26 p.m. UTC
wlroots major versions are usually incompatible. With
change to 0.18 wlroots has a different .pc pkg-config file
name, wlroots-0.18.pc. That means any package using pkg-config
to search for wlroots won't be able to find it. So even if there
were no breaking changes inside wlroots code base, it means programs
cannot be compiled against different major version.

I've thus exposed every wlroots as a separate symbol without the need
for use of "wlroots" symbol, so every package can use major wlroots version
appropriate for its version. I've kept wlroots symbol to not break anything
that is currently using it for wlroots-0.17.

* gnu/packages/wm.scm: Add wlroots-0.18, bind wlroots 0.17
to wlroots-0.17 symbol to make it easier to target specific
major wlroots version.

Change-Id: I377ed66e91b4adc1216d42077fe7c34178a5552b
---
 gnu/packages/wm.scm | 28 +++++++++++++++++++++++-----
 1 file changed, 23 insertions(+), 5 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 30ae699550..b558c1223c 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -1723,10 +1723,10 @@  (define-public polybar
 functionality to display information about the most commonly used services.")
     (license license:expat)))
 
-(define-public wlroots
+(define-public wlroots-0.18
   (package
     (name "wlroots")
-    (version "0.17.4")
+    (version "0.18.0")
     (source
      (origin
        (method git-fetch)
@@ -1735,7 +1735,7 @@  (define-public wlroots
              (commit version)))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "0niigjpy8xxrnw3v9b3bsksw2q3yy3qsa2xx0aazwpycw5zrff83"))))
+        (base32 "13avi2805wrfkghgc7ar273p61svmm85k3g3hg9bf2gaxsz6f91f"))))
     (build-system meson-build-system)
     (arguments
      `(#:phases
@@ -1782,9 +1782,25 @@  (define-public wlroots
 modules for building a Wayland compositor.")
     (license license:expat)))  ; MIT license
 
+(define-public wlroots-0.17
+  (package
+    (inherit wlroots-0.18)
+    (name "wlroots")
+    (version "0.17.4")
+    (source
+     (origin
+       (inherit (package-source wlroots-0.18))
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://gitlab.freedesktop.org/wlroots/wlroots")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0niigjpy8xxrnw3v9b3bsksw2q3yy3qsa2xx0aazwpycw5zrff83"))))))
+
 (define-public wlroots-0.16
   (package
-    (inherit wlroots)
+    (inherit wlroots-0.18)
     (name "wlroots-0.16")
     (version "0.16.2")
     (source
@@ -1801,7 +1817,7 @@  (define-public wlroots-0.16
 
 (define-public wlroots-0.15
   (package
-    (inherit wlroots)
+    (inherit wlroots-0.18)
     (name "wlroots-0.15")
     (version "0.15.1")
     (source
@@ -1814,6 +1830,8 @@  (define-public wlroots-0.15
        (sha256
         (base32 "00s73nhi3sc48l426jdlqwpclg41kx1hv0yk4yxhbzw19gqpfm1h"))))))
 
+(define-public wlroots wlroots-0.17)
+
 (define-public wl-mirror
   (package
     (name "wl-mirror")