[bug#75466] gnu: Add python-ngesh.

Message ID 363c8d863b0105d719b128bbd0176cb5c6dd994d.1736438970.git.navid.afkhami@mdc-berlin.de
State New
Headers
Series [bug#75466] gnu: Add python-ngesh. |

Commit Message

Navid Afkhami Jan. 9, 2025, 4:09 p.m. UTC
  * gnu/packages/bioinformatics.scm (python-ngesh): New variable.

Change-Id: If51f3075037647e319efa9468331677a845b30cb
---
 gnu/packages/bioinformatics.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)


base-commit: 66a1a1fe22aff54973ab5c33957a338b33b8274c
  

Patch

diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 34a39a48f1..f524b53bad 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -2880,6 +2880,33 @@  (define-public python-metacells
 cells).")
     (license license:expat)))
 
+(define-public python-ngesh
+  (package
+    (name "python-ngesh")
+    (version "1.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/tresoldi/ngesh")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "07sj4x95b5hvx57pw24f80sk4ag4hkg1z6wzym3pzi8n5gn85n1z"))))
+    (build-system pyproject-build-system)
+    (propagated-inputs (list python-ete3 python-numpy python-six))
+    (native-inputs (list python-black python-flake8 python-pytest python-twine
+                         python-wheel))
+    (home-page "https://github.com/tresoldi/ngesh")
+    (synopsis "Library for phylogenetic tree simulation")
+    (description
+     "Ngesh is a Python library and CLI tool for simulating phylogenetic trees and data.
+It is intended for benchmarking phylogenetic methods, especially in historical
+linguistics andstemmatology.  The generation of stochastic phylogenetic trees
+also goes by the name simulationmethods for phylogenetic trees, synthetic data
+generation, or just phylogenetic tree simulation.")
+    (license license:expat)))
+
 (define-public python-parabam
   (package
     (name "python-parabam")