diff mbox series

[bug#49094] gnu: Add video-contact-sheet

Message ID 3627c385f0509614621b154cd26dc9ed4f503a51.camel@courrier.dev
State Accepted
Headers show
Series [bug#49094] gnu: Add video-contact-sheet | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Pradana Adrinusa AUMARS June 18, 2021, 2:27 p.m. UTC
From 9851db2b3036ee3d5e8ef85ed8bae2f6398702e0 Mon Sep 17 00:00:00 2001
From: Pradana AUMARS <paumars@courrier.dev>
Date: Fri, 18 Jun 2021 16:13:07 +0200
Subject: [PATCH] gnu: Add video-contact-sheet

---
 gnu/packages/video.scm | 31 +++++++++++++++++++++++++++++++
 1 file changed, 31 insertions(+)

+   (description "This is a bash script meant to create video contact
sheets (previews) of videos. Any video supported by mplayer and ffmpeg
can be used. A note of warning: Unlike most similar tools it, by
default, makes screenshots the same size as the video, see below for
details on how to change this.
+
+Take a look at the documentation and/or use the –help and –fullhelp
options to learn how to use it.")
+   (home-page "http://p.outlyer.net/vcs/")
+   (license license:lgpl3)))

Comments

Sarah Morgensen July 23, 2021, 10:40 p.m. UTC | #1
Hello,

Thank you for the patch.  Unfortunately, I cannot apply it because your
mail client has wrapped some lines, corrupting the patch.  (Also, adding
to the end of the file rather than the middle tends to cause patches not
to apply, so probably avoid this as well.)

I do still have a few suggestions, annotated below:

Pradana Adrinusa AUMARS <paumars@courrier.dev> writes:

>>From 9851db2b3036ee3d5e8ef85ed8bae2f6398702e0 Mon Sep 17 00:00:00 2001
> From: Pradana AUMARS <paumars@courrier.dev>
> Date: Fri, 18 Jun 2021 16:13:07 +0200
> Subject: [PATCH] gnu: Add video-contact-sheet
>
> ---
>  gnu/packages/video.scm | 31 +++++++++++++++++++++++++++++++
>  1 file changed, 31 insertions(+)
>
> diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
> index e3f4f59b4c..ba3035cf45 100644
> --- a/gnu/packages/video.scm
> +++ b/gnu/packages/video.scm
> @@ -51,6 +51,7 @@
>  ;;; Copyright © 2021 Andrew Tropin <andrew@trop.in>
>  ;;; Copyright © 2021 David Wilson <david@daviwil.com>
>  ;;; Copyright © 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
> +;;; Copyright © 2021 Pradana Aumars <paumars@courrier.dev>
>  ;;;
>  ;;; This file is part of GNU Guix.
>  ;;;
> @@ -96,6 +97,7 @@
>    #:use-module (gnu packages avahi)
>    #:use-module (gnu packages backup)
>    #:use-module (gnu packages base)
> +  #:use-module (gnu packages bash)
>    #:use-module (gnu packages bison)
>    #:use-module (gnu packages boost)
>    #:use-module (gnu packages cdrom)
> @@ -5180,3 +5182,32 @@ information) NALUs (Network Abstraction Layer
> Unit) for inclusion into an h.264
>  elementary stream are provided.")
>      (home-page "https://github.com/szatmary/libcaption")
>      (license license:expat)))
> +
> +(define-public video-contact-sheet
> +  (package
> +   (name "video-contact-sheet")
> +   (version "1.13.4")
> +   (source (origin
> +            (method url-fetch)
> +            (uri (string-append "http://p.outlyer.net/vcs/files/vcs-"
> version
> +				".tar.gz"))

Lines should be wrapped at 80 characters when possible.  Indentation
should be with spaces instead of tabs.

Also, it looks like 'http://p.outlyer.net/vcs/files/' has a permanent
redirect to 'http://p.outlyer.net/files/vcs/' so that should be updated.

> +            (sha256
> +             (base32
> +              "0jsl93r0rnybjcipqbww5hwsr9ln6kz1qnf32qfxdvhfw52n27fw"))
> ))
> +   (build-system gnu-build-system)
> +   (arguments
> +    `(#:phases (modify-phases %standard-phases
> +                              (delete 'configure)
> +                              (delete 'build)
> +                              (delete 'check))
> +      #:make-flags (list (string-append "prefix=" (assoc-ref %outputs
> "out")))))
> +   (inputs
> +    `(("bash" ,bash)
> +      ("ffmpeg" ,ffmpeg)
> +      ("imagemagick" ,imagemagick)))
> +   (synopsis "Bash script to create contact sheets (preview images)
> from videos")
> +   (description "This is a bash script meant to create video contact
> sheets (previews) of videos. Any video supported by mplayer and ffmpeg
> can be used. A note of warning: Unlike most similar tools it, by
> default, makes screenshots the same size as the video, see below for
                                                             ^ the manual
> details on how to change this.
> +
> +Take a look at the documentation and/or use the –help and –fullhelp
> options to learn how to use it.")
This last sentence should probably not be in the description.

Please also wrap these lines at 80 characters as well (see other
packages for examples), and use two spaces between sentences.

> +   (home-page "http://p.outlyer.net/vcs/")
> +   (license license:lgpl3)))

--
Sarah
Pradana Adrinusa AUMARS Sept. 5, 2021, 8:52 a.m. UTC | #2
I've sent a new patch adding video-contact-sheet: bug 50369

https://debbugs.gnu.org/cgi/bugreport.cgi?bug=50369

Please close this issue, thanks.
diff mbox series

Patch

diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index e3f4f59b4c..ba3035cf45 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -51,6 +51,7 @@ 
 ;;; Copyright © 2021 Andrew Tropin <andrew@trop.in>
 ;;; Copyright © 2021 David Wilson <david@daviwil.com>
 ;;; Copyright © 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2021 Pradana Aumars <paumars@courrier.dev>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -96,6 +97,7 @@ 
   #:use-module (gnu packages avahi)
   #:use-module (gnu packages backup)
   #:use-module (gnu packages base)
+  #:use-module (gnu packages bash)
   #:use-module (gnu packages bison)
   #:use-module (gnu packages boost)
   #:use-module (gnu packages cdrom)
@@ -5180,3 +5182,32 @@  information) NALUs (Network Abstraction Layer
Unit) for inclusion into an h.264
 elementary stream are provided.")
     (home-page "https://github.com/szatmary/libcaption")
     (license license:expat)))
+
+(define-public video-contact-sheet
+  (package
+   (name "video-contact-sheet")
+   (version "1.13.4")
+   (source (origin
+            (method url-fetch)
+            (uri (string-append "http://p.outlyer.net/vcs/files/vcs-"
version
+				".tar.gz"))
+            (sha256
+             (base32
+              "0jsl93r0rnybjcipqbww5hwsr9ln6kz1qnf32qfxdvhfw52n27fw"))
))
+   (build-system gnu-build-system)
+   (arguments
+    `(#:phases (modify-phases %standard-phases
+                              (delete 'configure)
+                              (delete 'build)
+                              (delete 'check))
+      #:make-flags (list (string-append "prefix=" (assoc-ref %outputs
"out")))))
+   (inputs
+    `(("bash" ,bash)
+      ("ffmpeg" ,ffmpeg)
+      ("imagemagick" ,imagemagick)))
+   (synopsis "Bash script to create contact sheets (preview images)
from videos")