diff mbox series

[bug#70563,v2] gnu: Add pkcs11-helper.

Message ID 3592b94458c7dddc7f560e8238c8f9f4119eff8f.1715838075.git.atai@atai.org
State New
Headers show
Series [bug#70563,v2] gnu: Add pkcs11-helper. | expand

Commit Message

Andy Tai May 16, 2024, 5:42 a.m. UTC
* gnu/packages/security-token.scm (pkcs11-helper): New variable.

Change-Id: Ib17e0cf209a6fe797d0c797829ba91091b719028
---
 gnu/packages/security-token.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)


base-commit: 5a624adfd7b14c3717237d137bd0766c77f0f570

Comments

Zheng Junjie May 22, 2024, 5:34 a.m. UTC | #1
Andy Tai <atai@atai.org> writes:

> * gnu/packages/security-token.scm (pkcs11-helper): New variable.
>
> Change-Id: Ib17e0cf209a6fe797d0c797829ba91091b719028
> ---
>  gnu/packages/security-token.scm | 25 +++++++++++++++++++++++++
>  1 file changed, 25 insertions(+)
>
> diff --git a/gnu/packages/security-token.scm b/gnu/packages/security-token.scm
> index 35a8d4e216..78ddf5456b 100644
> --- a/gnu/packages/security-token.scm
> +++ b/gnu/packages/security-token.scm
> @@ -394,6 +394,31 @@ (define-public opensc
>  #15 standard and the PKCS #11 API.")
>      (license license:lgpl2.1+)))
>  
> +
> +(define-public pkcs11-helper
> +  (package
> +    (name "pkcs11-helper")
> +    (version "1.30.0")
> +    (source
> +     (origin
> +       (method url-fetch)
> +       (uri (string-append
> +             "https://github.com/OpenSC/pkcs11-helper/releases/download/pkcs11-helper-"
> +             version "/pkcs11-helper-" version ".tar.bz2"))
> +       (sha256
> +        (base32 "1ac86jfj4qfwzbvsg6l9r4w4bbwxj2i9qi4dy1nz5aqcj6x1an2c"))))
> +    (build-system gnu-build-system)
> +    (inputs (list openssl-1.1 pcsc-lite))

Can this package use openssl-3.0? As i known, openssl 1.1 is EOL,
see https://www.openssl.org/blog/blog/2023/03/28/1.1.1-EOL/index.html.
It is best not to add more openssl-1.1 dependencies.  other LGTM.

> +    (native-inputs (list pkg-config))
> +    (home-page "https://github.com/OpenSC/pkcs11-helper")
> +    (synopsis "Library that simplifies the interaction with PKCS#11 providers")
> +    (description
> +     "Pkcs11-helper is a library that simplifies the interaction with
> +PKCS#11 providers for end-user applications. PKCS#11 is published standard.
> +PKCS#11 is the de-facto standard to access cryptographic devices")
> +    (license (list license:gpl2 license:bsd-3))))
> +
> +
>  (define-public yubico-piv-tool
>    (package
>      (name "yubico-piv-tool")
>
> base-commit: 5a624adfd7b14c3717237d137bd0766c77f0f570
Andy Tai May 22, 2024, 6:16 a.m. UTC | #2
will check and possible update patch
diff mbox series

Patch

diff --git a/gnu/packages/security-token.scm b/gnu/packages/security-token.scm
index 35a8d4e216..78ddf5456b 100644
--- a/gnu/packages/security-token.scm
+++ b/gnu/packages/security-token.scm
@@ -394,6 +394,31 @@  (define-public opensc
 #15 standard and the PKCS #11 API.")
     (license license:lgpl2.1+)))
 
+
+(define-public pkcs11-helper
+  (package
+    (name "pkcs11-helper")
+    (version "1.30.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://github.com/OpenSC/pkcs11-helper/releases/download/pkcs11-helper-"
+             version "/pkcs11-helper-" version ".tar.bz2"))
+       (sha256
+        (base32 "1ac86jfj4qfwzbvsg6l9r4w4bbwxj2i9qi4dy1nz5aqcj6x1an2c"))))
+    (build-system gnu-build-system)
+    (inputs (list openssl-1.1 pcsc-lite))
+    (native-inputs (list pkg-config))
+    (home-page "https://github.com/OpenSC/pkcs11-helper")
+    (synopsis "Library that simplifies the interaction with PKCS#11 providers")
+    (description
+     "Pkcs11-helper is a library that simplifies the interaction with
+PKCS#11 providers for end-user applications. PKCS#11 is published standard.
+PKCS#11 is the de-facto standard to access cryptographic devices")
+    (license (list license:gpl2 license:bsd-3))))
+
+
 (define-public yubico-piv-tool
   (package
     (name "yubico-piv-tool")