diff mbox series

[bug#67289] gnu: qutebrowser: Update to 3.0.2.

Message ID 3514f2342b3788d19c49aa6e9e2971f3d31c892c.1700426152.git.herman@rimm.ee
State New
Headers show
Series [bug#67289] gnu: qutebrowser: Update to 3.0.2. | expand

Commit Message

Herman Rimm Nov. 19, 2023, 8:35 p.m. UTC
* gnu/packages/web-browsers (qutebrowser): Update to 3.0.2.
[source]: Bump version and recompute hash.
[inputs]: Use PyQt6, placed before PyQtWebengine.
[arguments]: Replace qt5 path with qt6 path.
[description]: Replace PyQt5 with PyQt6.
---
 gnu/packages/web-browsers.scm | 21 ++++++++++-----------
 1 file changed, 10 insertions(+), 11 deletions(-)


base-commit: 761810d32a0550912b5bb36a0c9f60141bcb7d20
prerequisite-patch-id: 8ae6d4a62bd979a3fe4758d95ed7fc0749063e9b
prerequisite-patch-id: 83df61ed11d3c78120bb78ef098bc182b7f2b300
prerequisite-patch-id: 889819768a466a7f2ccd7ca2ab21f0972563b8b0

Comments

Herman Rimm Nov. 20, 2023, 8:05 a.m. UTC | #1
I wanted to say that this patch depends on #57431, where the PyQt6 packages are added.

Cheers,
Herman Rimm
Sergey Trofimov Nov. 20, 2023, 10:40 a.m. UTC | #2
Herman Rimm <herman@rimm.ee> writes:

> I wanted to say that this patch depends on #57431, where the PyQt6 packages are added.
>
> Cheers,
> Herman Rimm

I can confirm, that this change + 3 patches from pyqt6 ticket build and
work fine on my machine (x86_64). Thanks for finally making it happen.
chris Nov. 21, 2023, 3:43 a.m. UTC | #3
I want this! thank you Herman
Wilko Meyer Jan. 14, 2024, 12:21 p.m. UTC | #4
Hi Guix,

I tested the changes made in v2 of this patch locally and qutebrowser
v3.1.0 builds fine (on x86_64). I kept tests disabled, as they partially
seem to lack dependencies (e.g. I assume python-boltons for urlutils?)
and I didn't want to invest time to resolve those. Anyways, thanks for
the patch/the possibility to be able to use a recent and usable
qutebrowser version again!
chris Jan. 15, 2024, 4:45 a.m. UTC | #5
After running guix reconfigure on my home config qutebrowser 3 was installed and now qutebrowser does not start. Here is the qutebrowser process shell output. Would anyone here recommend a solution?

```
$ qutebrowser
20:40:33 WARNING: Could not find the Qt platform plugin "wayland" in ""
20:40:33 CRITICAL: This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.

Available platform plugins are: offscreen, vnc, minimal, xcb, vkkhrdisplay, linuxfb, minimalegl, eglfs.

Fatal Python error: Aborted

Current thread 0x00007f36c07e6740 (most recent call first):
  File "/gnu/store/xc2z9q7z036ny3fipgqvwc01yn20j2jh-qutebrowser-3.1.0/lib/python3.10/site-packages/qutebrowser/app.py", line 545 in __init__
  File "/gnu/store/xc2z9q7z036ny3fipgqvwc01yn20j2jh-qutebrowser-3.1.0/lib/python3.10/site-packages/qutebrowser/app.py", line 80 in run
  File "/gnu/store/xc2z9q7z036ny3fipgqvwc01yn20j2jh-qutebrowser-3.1.0/lib/python3.10/site-packages/qutebrowser/qutebrowser.py", line 231 in main
  File "/gnu/store/xc2z9q7z036ny3fipgqvwc01yn20j2jh-qutebrowser-3.1.0/bin/.qutebrowser-real", line 33 in <module>

Extension modules: PyQt6.QtCore, PyQt6.QtGui, PyQt6.QtWidgets, markupsafe._speedups, yaml._yaml, PyQt6.QtNetwork, PyQt6.QtQml, PyQt6.QtOpenGL, PyQt6.QtDBus, PyQt6.QtPrintSupport, PyQt6.QtWebChannel, PyQt6.QtWebEngineCore, PyQt6.QtWebEngineWidgets, PyQt6.QtSql (total: 14)
```
diff mbox series

Patch

diff --git a/gnu/packages/web-browsers.scm b/gnu/packages/web-browsers.scm
index d38882046d..9257d541a8 100644
--- a/gnu/packages/web-browsers.scm
+++ b/gnu/packages/web-browsers.scm
@@ -21,6 +21,7 @@ 
 ;;; Copyright © 2021 Alexander Krotov <krotov@iitp.ru>
 ;;; Copyright © 2020 Hartmut Goebel <h.goebel@crazy-compilers.com>
 ;;; Copyright © 2021 Christopher Howard <christopher@librehacker.com>
+;;; Copyright © 2023 Herman Rimm <herman@rimm.ee>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -459,7 +460,7 @@  (define-public kristall
 (define-public qutebrowser
   (package
     (name "qutebrowser")
-    (version "2.5.4")
+    (version "3.0.2")
     (source
      (origin
        (method url-fetch)
@@ -467,7 +468,7 @@  (define-public qutebrowser
                            "qutebrowser/releases/download/v" version "/"
                            "qutebrowser-" version ".tar.gz"))
        (sha256
-        (base32 "1c8skkc5vjbvbslz65hzrj9d05v4zbcjbli61ikjmr174lhb4q54"))))
+        (base32 "0ldwslgakpcv3v47hli8lm68zndjsb7bj8rpp2pijd8j9bg96655"))))
     (build-system python-build-system)
     (native-inputs
      (list python-attrs))               ; for tests
@@ -480,15 +481,13 @@  (define-public qutebrowser
            python-pynacl
            python-pypeg2
            python-pyyaml
-           ;; FIXME: python-pyqtwebengine needs to come before python-pyqt so
-           ;; that it's __init__.py is used first.
-           python-pyqtwebengine
-           python-pyqt
-           ;; While qtwebengine-5 is provided by python-pyqtwebengine, it's
+           python-pyqt-6
+           python-pyqtwebengine-6
+           ;; While qtwebengine is provided by python-pyqtwebengine-6, it's
            ;; included here so we can wrap QTWEBENGINEPROCESS_PATH.
-           qtwebengine-5))
+           qtwebengine))
     (arguments
-     `(;; FIXME: With the existance of qtwebengine-5, tests can now run.  But
+     `(;; FIXME: With the existence of qtwebengine, tests can now run.  But
        ;; they are still disabled because test phase hangs.  It's not readily
        ;; apparent as to why.
        #:tests? #f
@@ -540,11 +539,11 @@  (define-public qutebrowser
              (wrap-program (search-input-file outputs "bin/qutebrowser")
                `("QTWEBENGINEPROCESS_PATH" =
                  (,(search-input-file
-                    inputs "/lib/qt5/libexec/QtWebEngineProcess")))))))))
+                    inputs "/lib/qt6/libexec/QtWebEngineProcess")))))))))
     (home-page "https://qutebrowser.org/")
     (synopsis "Minimal, keyboard-focused, vim-like web browser")
     (description "qutebrowser is a keyboard-focused browser with a minimal
-GUI.  It is based on PyQt5 and QtWebEngine.")
+GUI.  It is based on PyQt6 and QtWebEngine.")
     (license license:gpl3+)))
 
 (define-public vimb